Getting HTTP server error 404 with DAVx5 and Contact birthdays

Hi all, please forgive me if I’m in the wrong place, but I’m having trouble debugging this issue:

I’m using the DAVx5 Android app to synchronise my phone’s calendars and contacts with my self-hosted Nextcloud server (currently version 21.0.7). At some point while editing one of my appointments, the app crashed. After re-starting it, I keep getting the following error reported by the DAVx5 app:

Contact birthdays
HTTP server error - HTTP 404 Not Found

There is a “View item” button for the error which, when tapping, directs me to a contact birthday. I have tried to delete this person’s birthday from their contact entry but after re-entering, the error is back as well.

Looking into my server logs, I found this correlating with the app error: - myuser [02/Dec/2021:09:57:53 +1030] "PROPFIND /cloud/remote.php/dav/calendars/myuser/contact_birthdays/ HTTP/1.1" 207 7010 "-" "DAVx5/4.0-ose (2021/10/14; dav4jvm; okhttp/4.9.1) Android/11" - myuser [02/Dec/2021:09:58:03 +1030] "PUT /cloud/remote.php/dav/calendars/myuser/contact_birthdays/All%20contacts-292e4170-6a02-4fa5-98db-2328b4174299.vcf.ics HTTP/1.1" 404 1775 "-" "DAVx5/4.0-ose (2021/10/14; dav4jvm; okhttp/4.9.1) Android/11"

Any help on how to fix this would be appreciated.

There was a big report about this on github recently but I can’t find it right now.

@friendfx did you find a solution?

I also have this error now, after accidently deleting a.notification for.a birthday … now it seems,that my local calendar is different and it can’t be synced (uplpaded) anymore, since the calender is read-only by default :frowning:

Hey, found a solution:

  • deactivate Birthday-Calendar in Calender-Settings (in web frontend)
  • in DAVx5 rescan calenders (deactivate birthdays)
  • activate Birthday-Calender in NC
  • in DAVx5 rescan calenders
  • in DAVx5 activate birthday-calender

Does anybody know how to force read-only on that calender?

I had the issue after I added a notification to a birthday directly on my phone.

Thank you jeensg for the workaround. I had to do it twice, but it looks like it worked now.

For anyone following the instructions: “Deactivate Birthday-Calendar” is an option when you open the calendar settings with the dots in the lower left corner of the calendar page in NC.

As jeensg mentioned: if editing birthday events cause issues, the calendar should be read-only, but the option is not available in DavX for this calendar (for others, yes).