[Gelöst] Nach Update von 9.0.52 auf 10.0 Fehlermeldung: Die .htaccess-Datei funktioniert nicht

Hi Leute.

Nach Update auf 10.0 bekomme ich die Meldung:

Dein Datenverzeichnis und deine Dateien sind wahrscheinlich vom Internet
 aus erreichbar. Die .htaccess-Datei funktioniert nicht. Es wird 
dringend empfohlen, deinen Webserver dahingehend zu konfigurieren, dass 
das Datenverzeichnis nicht mehr vom Internet aus erreichbar ist oder 
dass du es aus dem Dokument-Root-Verzeichnis des Webservers bewegst.

Abgesehen davon funktioniert alles. Keine Probleme. Hat das noch jemand?

cheers
t.

Offenbar ist diese Warnung auch legitim. Ich kann mit wget auf Dateien zugreifen. So etwas wie:

wget https://domain/data/username/files/bla.mp3

funktioniert. Nach downgrade zu 9.0.52 bekomme ich bei dem wget command ein “403 Forbidden”.

Da stimmt etwas ganz und garnicht.

Hier mal die Specs meines Systems. Apache 2.4.23, PHP-7.0.10, Mariadb-10.1.16.

Nach etwas mehr Debugging konnte ich feststellen, dass wget doch nicht funktioniert. Ich war etwas irritiert weil ich kein
Forbidden bekam. Was ich bekam war ein HTML Dokument, dass mich zum Loginfenster weitergeleitet hat. Das beruhigt
mich ein bisschen. Es bleibt aber die Fehlermeldung unter “Sicherheits- & Einrichtungswarnungen”. Jemand ne Idee?

cheers
t.

Okay. Update Nummer 4. :slight_smile: Ich habe das Data Verzeichnis nun aus dem DocRoot wegbewegt und die config angepasst. Nun ist die Fehlermeldung verschwunden. Soll mir recht sein.

cheers
t.

Habe dasselbe Problem. Werde daher auch mal das Datenverzeichnis verschieben. Oder gibt es noch eine andere Lösung?

hier:

Ich habe das gleiche Problem, dass ein Zugriff via direkter url in das Datenverzeichnis möglich ist und die .htacces lt. NC 12 nicht greift: apacheconfig :

<Directory />
        Options FollowSymLinks
        AllowOverride None
        Require all denied
</Directory>

<Directory /usr/share>
    AllowOverride None
    Require all granted
</Directory>

<Directory /var/www/>
    Options Indexes FollowSymLinks
    AllowOverride All
    Require all granted
</Directory>

Rechteverwaltung :

/var/www/nextcloud/ : drwxr-xr-x 15 www-data www-data 4,0K Jun 30 08:41 nextcloud
/var/www/nextcloud/data : drwxr-x---  8 www-data www-data 4,0K MĂ€r 20 08:37 data

.htaccess im data verzeichnis : 
# Generated by Nextcloud on 2017-06-30 06:41:48
# line below if for Apache 2.4
<ifModule mod_authz_core.c>
Require all denied
</ifModule>

# line below if for Apache 2.2
<ifModule !mod_authz_core.c>
deny from all
Satisfy All
</ifModule>

# section for Apache 2.2 and 2.4
<ifModule mod_autoindex.c>
IndexIgnore *
</ifModule>

Edit : gelöst : Das Problem scheint beim Automatischen update aufzutreten. Nachdem ich das manuelle Update eingespielt habe ( https://docs.nextcloud.com/server/12/admin_manual/maintenance/manual_upgrade.html ) sind Datein aus dem data Verzeichnis nicht mehr erreichbar.