Fulltextsearch: No results in browser window

After days of trying and trying i’m absolute desperated, because the full text search doesn’t show anything in my browser. I mean it doesn’t show a search result, but it also doesn’t show a “no result”-message, only a blank white window is shown.
occ fulltextsearch:test says that all is OK and also a query with curl on the cli, e.g. 'curl -xGET ‘localhost:9200/my_index/_search?q=mondraker’, works fine and shows a lot of content.
But when i try this search in the browser nothing happens:

Nextcloud, PHP 7.2.17, Full Text Search 1.3.2, Full Text Search Elastic Platform 1.3.0, Full Text Search Files 1.3.0, Full Text Search Files Tesseract 1.3.0

What i’ve tried yet:

  1. occ fulltextsearch:reset & occ fulltextsearch:index
  2. removed all full text search apps from nextcloud, delete both full text search tables in database, delete all full text search entries in appconfig table. After that installing full text search apps again and create new index

Any further suggestions what i can do?

Result of occ fulltextsearch:test everything ok?
Errors with fulltextsearch:index?

Thank you for your fast response.
Everything was ok with fulltextsearch:test and also no errors with fulltextsearch:index.

Actually i’m on step 2 from my first posting (index is new building since yesterday 9 pm), maybe i have success after new index is finished.
(Would be a lot faster if there were a option to exclude dirs from indexing. Hundreds of Gigabytes in Photos there…)

I will give a feedback here.

You can set options during the index, and limit to some folders/users: https://github.com/nextcloud/fulltextsearch/wiki/Commands#fulltextsearchindex

You can also exclude folders by creating a .noindex file at the root of the folder.

1 Like

Is .noindex recursive working, e.g. if i put it in “Photos”, “Photos/Dogs” are excluded, too?

Everything works fine now, thanks to @ralfi and @Cult for your support!

1 Like

yes, of course

what was the solution? same problem for me

is the index over, do you have errors during the index or test ?

I had the same problem. The reason was probably that I indexed some unnecessary directories that contained a lot of metadata.

so I excluded the unneeded directories with the .noindex file described here from the search, reset the search index and rebuilt it. Since then it works.


i have the same Problem.
i get this Error Message in he Logs

ntext	500 - {"request":{"providers":["files"],"author":"lars","search":"ratingen","page":1,"size":20,"parts":["comments","ocr"],"queries":[],"options":{"files_within_dir":"","files_local":"","files_external":"","files_extension":""},"metatags":[],"subtags":[],"tags":[]},"version":"1.4.1","status":-1,"exception":"Elasticsearch\\Common\\Exceptions\\BadRequest400Exception","message":"{\"error\":{\"root_cause\":[{\"type\":\"x_content_parse_exception\",\"reason\":\"[1:63] [bool] failed to parse field [should]\"}],\"type\":\"x_content_parse_exception\",\"reason\":\"[1:63] [bool] failed to parse field [must]\",\"caused_by\":{\"type\":\"x_content_parse_exception\",\"reason\":\"[1:63] [bool] failed to parse field [should]\",\"caused_by\":{\"type\":\"x_content_parse_exception\",\"reason\":\"[1:63] [bool] failed to parse field [should]\",\"caused_by\":{\"type\":\"illegal_state_exception\",\"reason\":\"expected value but got [START_ARRAY]\"}}}},\"status\":400}"}

Issue has already been reported. Please see https://github.com/nextcloud/fulltextsearch_elasticsearch/issues/106 for a hot-fix.

Okay i Running elasticsearch 7.7.0.
I try the hotfix