Fulltextsearch_elasticsearch max file size

Hi, I have just installed Nextcloud 13.0.1 on a Debian 9 virtual machine, and am in the process of configuring fulltextsearch_elasticsearch to index an archive of PDF documents.

Please note that the stack is working and indexing correctly, just not documents over 20mb, the default, and attempting to change the value in the admin interface simply does not work (the field does not change colour to indicate that has made an attempt to update the value).

Before moving the installation to a different directory within the server, it appears I was able to

Please delete everything above when creating your topic and provide the following:

Nextcloud 13.0.1 tarball
Debian 9
Apache 2.4.25
PHP 7.0.27

Is this the first time you’ve seen this error? Yes

Steps to replicate it:

  1. Install Nextcloud, fulltextsearch and fulltextsearch_elasticsearch
  2. Visit /settings/admin/fulltextsearch
  3. Choose Elasticsearch plugin, and attempt to change Max File Size to any figure larger than the default

The output of your Nextcloud log in Admin > Logging:

Nothing relevant

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'instanceid' => 'xxxxxx',
  'passwordsalt' => 'xxxx',
  'secret' => 'xxx',
  'trusted_domains' => 
  array (
    0 => 'xxx',
  'datadirectory' => '/xxx/xxx/data',
  'overwrite.cli.url' => 'https://xxx',
  'dbtype' => 'pgsql',
  'version' => '',
  'dbname' => 'nextcloud',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'dbuser' => 'xxx',
  'dbpassword' => 'xxx',
  'installed' => true,
  'overwrite.cli.url' => 'https://xxx',
  'htaccess.RewriteBase' => '/',
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'maintenance' => false,

The output of your Apache/nginx/system log in /var/log/____:

No relevant log entries that I can find