FTL Capability error

Thank you Stuart,
Like others I have this message Well, this is embarrassing, but that’s in french : Bon, c’est embarrassant, nous ne pouvons connecter votre document. Veuillez réessayer.
Still very annoying as I am dying to be able to use this wonderful alliance with Nextcloud.
Thanks to your docker tips, Stuart, I could easily locate the logs from Collabora.
And there is a fast running warning :

loolforkit version details: 2.0.2 - 2.0.2
frk-30612-30612 12:57:10.359245 [ loolforkit ] FTL Capability cap_sys_chroot is not set for the loolforkit program.| kit/ForKit.cpp:145
frk-30612-30612 12:57:10.359260 [ loolforkit ] FTL Capability cap_mknod is not set for the loolforkit program.| kit/ForKit.cpp:145
frk-30612-30612 12:57:10.359268 [ loolforkit ] FTL Capability cap_fowner is not set for the loolforkit program.| kit/ForKit.cpp:145

How can I set these three cap_sys_chroot, cap_mknod and cap_fowner ?

Not sure really as you shouldn’t have to, that is something to do with the docker install.

I should say with docker don’t install from your distro’s standard repo as its lags behind current versions.

I would do a google for your distro and docker such as Ubuntu docker which would return the following.

You need to follow the docker install they provide for the distro you are running.

Posting the results of docker info here would also help much.

The output of docker info is prob the first port of call to post here with the docker logs as there is much distro variance.

Hello Stuart, I use Debian.
Here’s the docker info

Containers: 2
Running: 1
Paused: 0
Stopped: 1
Images: 2
Server Version: 1.13.1
Storage Driver: aufs
Root Dir: /var/lib/docker/aufs
Backing Filesystem: extfs
Dirs: 20
Dirperm1 Supported: true
Logging Driver: json-file
Cgroup Driver: cgroupfs
Volume: local
Network: bridge host macvlan null overlay
Swarm: inactive
Runtimes: runc
Default Runtime: runc
Init Binary: docker-init
containerd version: aa8187dbd3b7ad67d8e5e3a15115d3eef43a7ed1
runc version: 9df8b306d01f59d3a8029be411de015b7304dd8f
init version: 949e6fa
Kernel Version: 3.16.0-4-amd64
Operating System: Debian GNU/Linux 8 (jessie)
OSType: linux
Architecture: x86_64
CPUs: 12
Total Memory: 11.48 GiB
Name: s4
Docker Root Dir: /var/lib/docker
Debug Mode (client): false
Debug Mode (server): false
Registry: https://index.docker.io/v1/
WARNING: No memory limit support
WARNING: No swap limit support
WARNING: No kernel memory limit support
WARNING: No oom kill disable support
WARNING: No cpu cfs quota support
WARNING: No cpu cfs period support
Experimental: false
Insecure Registries:
Live Restore Enabled: false

Probably aufs and the need to get docker to use device-mapper.

But first off how did you install docker as the standard debian repo isn’t very current.

Follow https://docs.docker.com/engine/installation/linux/debian/

uninstall docker

Use the docker repos’s

Install docker

Then from the docker documentation get docker.d to use device-mapper rather than aufs.

mkdir /etc/systemd/system/docker.service.d
nano /etc/systemd/system/docker.service.d/execWithDeviceMapper.conf

Create like so (paste):
ExecStart=/usr/bin/dockerd --storage-driver=devicemapper -H fd://

Check the last line is correct by grep ExecStart /lib/systemd/system/docker.service
Just to check it is -H fd://

See how you go.

Thank you so much Stuart,
Yes, this is the solution (device-mapper rather than aufs) that I followed. And it works making Collabora rocks !
It is wonderful. With Collabora, Nextcloud become more than ever the center piece of online office and modern collaboration. And thanks to you !

1 Like