Frontend works very slow

I am running Nextcloud AIO in docker. The problem is web frontend works very slow. It takes about a 1-2 min to load a page. Sometimes it starts to work normal, but it lasts for a few minutes.

version: "3.8"

    name: nextcloud_aio_mastercontainer
    image: nextcloud/all-in-one:latest
    restart: always
    container_name: nextcloud-aio-mastercontainer 
      - nextcloud_aio_mastercontainer:/mnt/docker-aio-config 
      - /var/run/docker.sock:/var/run/docker.sock:ro 
      - 3388:8080
    environment: # Is needed when using any of the options below
      - PUID=1000
      - PGID=1000
      # - AIO_DISABLE_BACKUP_SECTION=false # Setting this to true allows to hide the backup section in the AIO interface.
      # - APACHE_PORT=11000 # Is needed when running behind a web server or reverse proxy (like Apache, Nginx and else). See
      # - APACHE_IP_BINDING= # Should be set when running behind a web server or reverse proxy (like Apache, Nginx and else) that is running on the same host. See
      - NEXTCLOUD_DATADIR=/mnt/cloud/nextcloud-aio/data/
      - NEXTCLOUD_MOUNT=/mnt/
      - OVERWRITEHOST=*******
nginx conf
map $http_upgrade $connection_upgrade {
    default upgrade;
    '' close;

server {
    listen 80;

    if ($scheme = "http") {
        return 301 https://$host$request_uri;

    listen 443 ssl http2;
    # listen [::]:443 ssl http2; # comment to disable IPv6

    server_name *********;

    location / {

        proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
        proxy_set_header X-Forwarded-Port $server_port;
        proxy_set_header X-Forwarded-Scheme $scheme;
        proxy_set_header X-Forwarded-Proto $scheme;
        proxy_set_header X-Real-IP $remote_addr;
        proxy_set_header Accept-Encoding "";
        proxy_set_header Host $host;
        client_body_buffer_size 512k;
        proxy_read_timeout 86400s;
        client_max_body_size 0;

        # Websocket
        proxy_http_version 1.1;
        proxy_set_header Upgrade $http_upgrade;
        proxy_set_header Connection $connection_upgrade;

    ssl_certificate /etc/letsencrypt/live/**********/fullchain.pem;   # managed by certbot on host machine
    ssl_certificate_key /etc/letsencrypt/live/**********/privkey.pem; # managed by certbot on host machine

    ssl_session_timeout 1d;
    ssl_session_cache shared:MozSSL:10m; # about 40000 sessions
    ssl_session_tickets off;

    ssl_protocols TLSv1.2 TLSv1.3;
    ssl_ciphers ECDHE-ECDSA-**********;
    ssl_prefer_server_ciphers off;
Portainer (screenshot)

Chrome network (screenshot)

Nextcloud version : 26.0.3
Operating system and version: Debian 11
Nginx version: nginx 1.18.0

Older CPUs have issues with AIO, I also had the same issue and upgraded my server
which solved the issue (loading time right now is 30 - 45 sec)
the Nextcloud AIO is a bit heavy on the operating system. Loading times are long…

My server specs:
Intel i5 3570K
4gb RAM

Is it old for that?

Hi, can you follow How to debug performance issues with Nextcloud? · nextcloud/all-in-one · Discussion #2475 · GitHub?

Sorry for the long answer. But that didn’t help, unfortunately

Just turned Collabora off. Works perfect!
That was the reason