Fresh install on CentOs, files do not load, welcome screen is always appearing


#1

Nextcloud version : 15.0.2
Operating system and version : CentOS 6
Apache or nginx version: Apache 2.4.34
PHP version : 7.2.10

The issue you are facing:

I did a fresh install on my server.
After login, I always see the welcome screen and the files never load (i only haev the demo files). If i go to “Recent” or “Gallery” screen, they appear, but not in normal mode.

I noticed that I have a 403 response in PROPFIND and DELETE methods.

Is this the first time you’ve seen this error? : Y

Steps to replicate it:

  1. Login to nextcloud
  2. Files will never show up

The output of your Nextcloud log in Admin > Logging:

{"reqId":"XH53IdHkjrFTgaCP7JnduwAAAMM","level":3,"time":"2019-03-05T13:18:25+00:00","remoteAddr":"91.206.82.5","user":"--","app":"PHP","method":"GET","url":"\/","message":"You are using a fallback implementation of the intl extension. Installing the native one is highly recommended instead. at \/home\/hoinari\/nextcloud\/3rdparty\/patchwork\/utf8\/src\/Patchwork\/Utf8\/Bootup\/intl.php#18","userAgent":"Mozilla\/5.0 (Windows NT 10.0; Win64; x64; rv:65.0) Gecko\/20100101 Firefox\/65.0","version":""}
{"reqId":"XH53P9HkjrFTgaCP7JndzgAAAMI","level":3,"time":"2019-03-05T13:19:08+00:00","remoteAddr":"91.206.82.5","user":"chip","app":"PHP","method":"POST","url":"\/index.php","message":"You are using a fallback implementation of the intl extension. Installing the native one is highly recommended instead. at \/home\/hoinari\/nextcloud\/3rdparty\/patchwork\/utf8\/src\/Patchwork\/Utf8\/Bootup\/intl.php#18","userAgent":"Mozilla\/5.0 (Windows NT 10.0; Win64; x64; rv:65.0) Gecko\/20100101 Firefox\/65.0","version":"15.0.2.0"}
{"reqId":"XH53TNHkjrFTgaCP7JndzwAAAMM","level":3,"time":"2019-03-05T13:19:13+00:00","remoteAddr":"91.206.82.5","user":"chip","app":"PHP","method":"GET","url":"\/index.php\/apps\/files\/","message":"You are using a fallback implementation of the intl extension. Installing the native one is highly recommended instead. at \/home\/hoinari\/nextcloud\/3rdparty\/patchwork\/utf8\/src\/Patchwork\/Utf8\/Bootup\/intl.php#18","userAgent":"Mozilla\/5.0 (Windows NT 10.0; Win64; x64; rv:65.0) Gecko\/20100101 Firefox\/65.0","version":"15.0.2.0"}
{"reqId":"XH53UVFXSMMXgYFD@q5TXQAAAAI","level":3,"time":"2019-03-05T13:19:13+00:00","remoteAddr":"91.206.82.5","user":"chip","app":"PHP","method":"GET","url":"\/index.php\/css\/core\/339f-4139-server.css?v=db81cddf52fdb3c8ca1e4c859e214124-1d2112fc-0","message":"You are using a fallback implementation of the intl extension. Installing the native one is highly recommended instead. at \/home\/hoinari\/nextcloud\/3rdparty\/patchwork\/utf8\/src\/Patchwork\/Utf8\/Bootup\/intl.php#18","userAgent":"Mozilla\/5.0 (Windows NT 10.0; Win64; x64; rv:65.0) Gecko\/20100101 Firefox\/65.0","version":"15.0.2.0"}
{"reqId":"XH53UVFXSMMXgYFD@q5TXgAAABE","level":3,"time":"2019-03-05T13:19:14+00:00","remoteAddr":"91.206.82.5","user":"chip","app":"PHP","method":"GET","url":"\/index.php\/css\/core\/339f-4139-css-variables.css?v=db81cddf52fdb3c8ca1e4c859e214124-1d2112fc-0","message":"You are using a fallback implementation of the intl extension. Installing the native one is highly recommended instead. at \/home\/hoinari\/nextcloud\/3rdparty\/patchwork\/utf8\/src\/Patchwork\/Utf8\/Bootup\/intl.php#18","userAgent":"Mozilla\/5.0 (Windows NT 10.0; Win64; x64; rv:65.0) Gecko\/20100101 Firefox\/65.0","version":"15.0.2.0"}


The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

<?php
$CONFIG = array (
  'instanceid' => 'ocaroi35pb12',
  'passwordsalt' => 'u7ZxiGcAzwa0i83EVMgPGIpTk9E1QJ',
  'secret' => 'iSrBYwgi1rmvio95tOZZn6IBNv8s91lsUZ9yj171vVtk3pMx',
  'trusted_domains' => 
  array (
    0 => 'nextcloud.doihoinari.ro',
  ),
  'datadirectory' => '/home/hoinari/nextcloud/data',
  'dbtype' => 'mysql',
  'version' => '15.0.2.0',
  'overwrite.cli.url' => 'https://nextcloud.doihoinari.ro',
  'dbname' => 'xxx',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'dbuser' => 'xxx',
  'dbpassword' => 'xxx',
  'installed' => true,
);

The output of your Apache/nginx/system log in /var/log/____:

PASTE HERE

#2
  1. better delete the secrets and credentials from your post.
  2. what is the state of selinux on your machine? you may check with sestatus.
  3. there is a special chapter about nextcloud, centos and selinux. did you read and apply it?

#3

SELinux status = disabled

I will check the chapter about centos, i did not know about it. I was using Ubuntu and switched to a new server. On Ubuntu everything worked out of the box.

Mean while I installed the intl extension, so that error is gone.


#4

Problem solved - mod_security was blocking the requests.