Folder "Talk", only owns files, someone

Someone can’t open a file from a conversation.
At the same time, previews in conversations are working.
In the folder “Talk” of these users only have their own files, there aren’t shared files.
In Firefox and Chrome wrong, the Android Talk app and WebDAV work well for these users.
Other accounts are alright - there are shared files in their folder Talk, in these same clients.

NextCloud ver 24.0.7 – docker
Update 2022-11-06, seems all was right after update.

Any special in the log I don’t see
“Deprecated event type for OCA\Files::loadAdditionalScripts: Symfony\Component\EventDispatcher\GenericEvent is used”
But these messages for good and wrong users.

Hope somebody could help me.
Greetings Roman

it seems the same by me :

Privileges on some files were lost. (granted implicit through conversation).

  • I “impersonate”-ed some problem user,
  • tried open a file in conversation,
  • caught (detected) error “has no provider set, performing full setup” (log, level=0),
  • found the file and user,
  • then logged the user and gave the needed grant,
  • tried opening a file (in conversation, the first user) again and detect next error (file).

warning: when you open a file, check also old-old posts. I opened a file and become quiet (calm), but file in old posts didn’t open, same error.

Wrong (addition to previous notice):
I tried update
UPDATE oc_mounts SET mount_provider_class = 'OCA\Files_Sharing\MountProvider' ...
After that background (perhaps) job deleted the record from oc_mounts.
Of course, the file was not shared anymore so the record is a mistake. :-((


can I help you?
Some details?
I think, my message isn’t so clear.
Feel free.

sorry, my english is very bad :slight_smile:
I do not quite understand… is the error supposed to go away after running this command?

UPDATE oc_mounts SET mount_provider_class = 'OCA\Files_Sharing\MountProvider' ...

Issue related? [Bug]: Missing shared files/directory in shared folder · Issue #34976 · nextcloud/server · GitHub

sorry, my english is very bad

my English is a bit, too

do not quite understand… is the error supposed to go away after running this command?
UPDATE oc_mounts SET mount_provider_class = 'OCA\Files_Sharing\MountProvider' ...

Someone recommend this way. I try to say that it’s wrong (bad)
You will lose information after that.

1 Like

Hi XueSheng-NC
I do not know exactly what you mean… I have try to apply the patch as this but I do not understand the output:

root@nextcloud-clone:/var/www/nextcloud/apps/files_sharing/lib/Controller# patch -p 1 < ~/34840.patch

can’t find file to patch at input line 18
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:

|From ff653f4d762b03bbb1c6ede5b450133748adac7a Mon Sep 17 00:00:00 2001
|From: Carl Schwan
|Date: Mon, 10 Oct 2022 16:09:14 +0200
|Subject: [PATCH 1/3] Propagate attributes when resharing
|When updating a share, load the node from the initiator instead of the
|owner similar to how this is done when creating the share.

Signed-off-by: Carl Schwan
1 file changed, 20 insertions(+), 27 deletions(-)
diff --git a/apps/files_sharing/lib/Controller/ShareAPIController.php b/apps/files_sharing/lib/Controller/ShareAPIController.php
index 66b3153f0995…8ceb6318637f 100644
— a/apps/files_sharing/lib/Controller/ShareAPIController.php
+++ b/apps/files_sharing/lib/Controller/ShareAPIController.php

File to patch:

Can you find
“has no provider set, performing full setup”
in nextcloud.log

Please take that patch with care. As mentioned in the issue tracker: backup your data first!
Regarding the patching, you used the wrong path. In your case it should be:

# cd /var/www/nextcloud
# patch -p 1 < ~/34840.patch

i have try this bevore, but this give this errors:

root@nextcloud-clone:/var/www/nextcloud# patch -p 1 < ~/34840.patch
patching file apps/files_sharing/lib/Controller/ShareAPIController.php
Hunk #1 FAILED at 525.
Hunk #2 FAILED at 685.
Hunk #3 FAILED at 1104.
Hunk #4 FAILED at 1253.
Hunk #5 FAILED at 1902.
Hunk #6 FAILED at 1916.
6 out of 6 hunks FAILED – saving rejects to file apps/files_sharing/lib/Controller/ShareAPIController.php.rej
patching file apps/files_sharing/lib/Controller/ShareAPIController.php
Reversed (or previously applied) patch detected! Assume -R? [n]

The patch you are trying to apply is not matching your Nextcloud version!
Btw. what’s this patch “34840” about? This is not the one which I referred to!

oh… i am so sorry :smiling_face:
now i have try this patch out of your link:
ist this ok? ich bin verwirrt
my Version
Nextcloud Hub 3 (25.0.1)

running this patch brings this:
root@nextcloud-clone:/var/www/nextcloud# patch -p 1 < 35155.patch
patching file apps/files_sharing/lib/Controller/ShareAPIController.php
Hunk #1 succeeded at 537 with fuzz 1 (offset 12 lines).
Hunk #2 FAILED at 679.
Hunk #3 succeeded at 1112 (offset 13 lines).
Hunk #4 succeeded at 1263 (offset 15 lines).
Hunk #5 FAILED at 1897.
Hunk #6 succeeded at 1932 (offset 12 lines).
2 out of 6 hunks FAILED – saving rejects to file apps/files_sharing/lib/Controller/ShareAPIController.php.rej

Patch was done for NC24 as you can see at the pull description [stable24] Revert "Propagate attributes when resharing" by szaimen · Pull Request #35155 · nextcloud/server · GitHub

You could try check the required changes for NC25 and modify the files accordingly (manually). Or you just wait until something is ready to test for NC25.

Just to make one thing clear: I don’t know whether this patch does solve your issue anyways! I did just mention this issue, because it might (!) be related.

ok… thank you very much, i will wait then,
it’s just strange that this problem only occurs with my user account, all other users have this not

no, this entry does not exist

no, this entry does not exist

be sure that
‘loglevel’ => 0,
in your config.php

and try reload wrong file

it was “loglevel 2”
i changed it, tried to load the file again and now i have the entries:
{“reqId”:“GEbC9NP1Aq0BDmByQS8Y”,“level”:0,“time”:“2022-11-15T11:44:03+00:00”,“remoteAddr”:“”,“user”:“trixi”,“app”:“no app in context”,“method”:“PROPFIND”,“url”:“/remote.php/dav/files/trixi/Talk/20221025_132720%20(2).png”,“message”:“mount at /trixi/files/Talk/Bild11.png/ has no provider set, performing full setup”,“userAgent”:“Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:106.0) Gecko/20100101 Firefox/106.0”,“version”:“”,“data”:}

Discussion around [Bug]: Shares missing in web when 'mount_provider_class' is empty · Issue #34752 · nextcloud/server · GitHub seems to get more precise now. Thus I assume there’ll be a fix or at least solid workaround soon.