Folder(s) won't be synced to Windows [Server -> Client sync problem]

Hello there,

I’m facing some problems with a small NC installation I am running (~ 10 users). Sometimes some shared folders will only appear in the webinterface of a user but are not synced to Windows. At the moment this holds true for a folder created 8 days ago by another user which is a subfolder and inherits its “shared”-property from the parent folder: it won’t sync for any other user, but everyone can see it in the webinterface.

I couldn’t find anything on the forum/google, there are also no errors within the SyncClient, the folder simply does not exist. However, if I choose to add another folder-sync in the Windows Client, the affected folder is shown in the server-side file tree!

Any ideas? Any caches of the WindowsClient that could be flushed? More infos needed?

Thank you so much in advance!


Nextcloud version: 14.0.3
Operating system and version: Windows 10
Apache or nginx version: unknown
PHP version: 7.0.32
Windows Client version(s): 2.3.1 and 2.5.1

1 Like

You might have not selected the folder in the windows app!
Open the NC windows app, click the arrow next to the the green tick, and it will show you all the folders, make sure that they are selected.

BUT! If they are, then untick the folder, click apply, make sure that its gone from your local directory, then tick it again and apply. It should sync up.

otherwise, check the activity in the app, and the log in the NC admin, there might be an issue with the directory.

Hey thanks for your answer!

Unfortunately, the folder is not even displayed in the Sync Tab - so I cannot tick the sync-box. Only if I choose “Add folder-sync [Ordner-Synchronisation hinzufügen]”, at the end of the Sync Tab, said folder will be displayed in the foldertree within the popup.

I tried unticking the parent folder - that didn’t work. I also already looked through both logs and couldn’t find anything concerning that folder :frowning:

Most probably it would help to delete the account and reconnect it - but that would be pretty annoying doing it on a regular basis (whenever we realize there is a folder missing) for 10 people…

So i hoped there might be a Cache or something (most probably within the NC windows app), that could be erased so it fetches the folder tree anew or something along that line? Or a known error as to why some folders won’t sync in general…

Thank you!

Recreating the account might solve the problem temporarily, I wouldn’t advice on this. Maybe once, just in case if there was a problem creating the account, or even reinstalling the app on ur desktop (just make sure you fully delete the folder from ur PC)
But first, try this via SSH…

sudo -u www-data php /usr/share/nginx/nextcloud/occ files:cleanup
sudo -u www-data php /usr/share/nginx/nextcloud/occ files:scan --all
sudo -u www-data php /usr/share/nginx/nextcloud/occ files:scan-app-data

Thanks for posting; I’m having the same issue, NC 15.0.2, Client Version 2.5.1final (build 20181204))
I created folder F, and shared it with group G.
Then a member from group G created subfolder SF.
Folder SF is visible for me in the webbrowser, but nowhere to be found in de Windows client.

Wait a minute… in the activity log it says:
Filename contains trailing spaces. Renamed the folder (it had a space behind the folder name).
Fixed it.

Was that your problem as well?

Regards, Jeroen