[Fixed] Nextcloud 23: Collabora not working on some users


Iv been experiencing some issues on my nextcloud with collabora office, it works fine for most of my nextcloud users but some users when they open a document it just stays on the loading screen and collabora never opens.

i have the latest collabora installed with the latest collabora nextcloud app, i think the problem is nextcloud because i also tried with an older version of collabora on a diferent server but on the same nextcloud and the problem is the same.

whats wierd for me is that it works fine for most of my users, but at least 2 or 3 just wont open for them, so i have no idea what the problem is :frowning:

here is a screen of the chrome console error that i get when one of those users try to open a document

no one? :frowning:

still needing help :frowning:

Hey @javito see conversation here: Nextcloud 23 installed under Nginx: extremely slow response. Without knowing your webserver/DB config it’s hard to say if this is the same issue, but checking that thread and a few others re: N23, it seems there are some issues related to Collabora and a little ways off from production-ready. In my case I rolled back to N22 and will chill there until it is confirmed to be running smoothly for others.

well, iv been thinking about going to 22, but since i installed this server fresh on 23, how can i go back to 22 without having to do the whole setup all over again? :frowning:

I don’t think downgrading from 23 to 22 is a trivial endeavour :-/ in my case I used a recent backup which was quick and easy.

So i finally fix it, looking at the journal log i found this:

coolwsd error

then i though… could it be that simple? what i did was to switch the language and locale of the user nextcloud account that were having the issue to English US and English (United States) and voala!, problem solved lol, after hours and hours of searching on the web and posting on forums without been able to find any clues, i finally manage to figure it out on my own, i hope anyone that come across this error can find peace with this post :slight_smile: