First install - Rock64 -404 page

Hi,
My first try to install NC on Rock64 is not successful… :frowning_face:
I used etcher to flash a new microSD card with NextCloudPi_Rock64_03-28-20.
It boot, but get “spinlock lockup suspected on cpu” bug. I tried to restart many times, messages are not always the same, but I never been able to reach installation screen.
What I’m supposed to do now to solve the problem?
Thanks
Mel

Update of today’s trials.
I download the images Debian Armbian Buster.
I tried curl script as mentioned but it says “distro is not supported”
My best chance was through the automatic installation proposed by armbian. I think it was installed, since I was able to see the login page at https://ip. However I was never been able to log in. I tried many passwords, tried to changed it in ncp-config, but nothing works.
I’m certainly missing a step somewhere, but I don’t know which one… :thinking:
Mel

Did you check md5sum of downloaded image file?
Tried other software to create microSD?
On Linux I use dd and it never fails.

Hi.
Some weeks of vacation later, but didn’t help. I re-create the SD card (md5 is fine).
This time I’m stuck to a 404 not found for https://192.168.0.103

cat: /usr/local/etc/ncp-version: Aucun fichier ou dossier de ce type
Running nc-info
Gathering information...
cat: /usr/local/etc/ncp-version: Aucun fichier ou dossier de ce type
NextCloudPi version
distribution         Armbian 20.08.1 Buster \l 
automount            no
USB devices          none
datadir              /var/www/nextcloud/data
data in SD           yes
data filesystem      ext2/ext3
data disk usage      4,5G/29G
rootfs usage         4,5G/29G
swapfile             /dev/zram1
dbdir                /var/lib/mysql
Nextcloud check      ok
Nextcloud version    19.0.2.2
HTTPD service        up
PHP service          up
MariaDB service      up
Redis service        up
Postfix service      up
internet check       ok
port check 80        closed
port check 443       closed
IP                   192.168.0.103
gateway              192.168.0.1
interface            eth0
certificates         none
NAT loopback         no
uptime               46min


You should run Lets Encrypt for trusted encrypted access

You should open your ports for Lets Encrypt and external access
Done. Press any key...

Do I really need to open ports? For now, I’m just trying to install on my own network. I read many times instructions. I found a SSH in config. It had a *, but I click on it and now it’s seem disabled and I’m unable to get it back enable:

Running SSH
Synchronizing state of ssh.service with SysV service script with /lib/systemd/systemd-sysv-install.
Executing: /lib/systemd/systemd-sysv-install disable ssh
SSH disabled
Done. Press any key...

Someone have an idea of what I’m supposed to do now?
Thanks

sudo systemctl start ssh.service
sudo systemctl enable ssh.service
sudo systemctl status ssh.service

You do not need to forward ports if you are only using it from within LAN.
But port 80 anf 443 need to be available for NC (no other aplication using them) and :4443 to access ncp-web and port :22 for ssh.