Files uploaded via S3 Bucket not indexed by NextCloud

Hello! Recently I created a ec2 instance on AWS to run a nextcloud. I also added external storage to be used in a S3 Bucket. Since my ec2 instance doesn’t have all the power, I uploaded some files directly to the S3 bucket. The problem that I’m facing is that my files doesn’t appear on NextCloud. So they aren’t indexed. Is there any way that I can make this sync happen?
Cheers

did you try to run “sudo -u www-data php occ files:scan --all”

https://docs.nextcloud.com/server/13/admin_manual/configuration_server/occ_command.html#file-operations-label

hi,

i’ve launch this command, and no way … nc don’t index files :frowning:

how can i check what is wrong in php code ? which file must be reviewed ?

according to files in a s3 bucket or in genarel?
what is the error message?

No errors …
Just NC seem to scan from db … rather than scan with S3 API file list …

s3 as primary storage or just mounted as external storage?

As external storage ;(
why ?

in this case i would suggest to open an issue in github.

if you tried to upload files directly to an s3 bucket used as primary storage i would be astonished if that was working.

Hello, I’m experiencing the same issue, but in my case I configured S3 as primary storage.

When I run occ files:scan --all no result is found. I see the issue after updating to NextCloud 19.0.9.

Any suggestion on how to debug this?

I am running Nextcloud as a container (GKE) and the storage is backed by a bucket on GCP.

I am trying to import files into Nextcloud database with files:scan command, but it doesn’t seem to work. I tried it using the following:

  • /var/www/html/data/<file>
  • /var/www/html/data/admin/<file>
  • <bucket>/<file>
  • <bucker>/admin/<file>

What is the right away? It was working when the data folder was mounted to the file system, but we had a requirement to back the data with a bucket.