Files, Photos, Nextcloud office all broken

I setup nextcloud on namecheap hosting with cpanel. I have SSH enabled, SSL working, etc.
Installed by uploading setup-nextcloud.php and running that from my domain.
MySQL was easy to setup. PHP seems to be setup correctly too.

The install goes fine and nextcloud boots up. I can add apps, users, etc. But I have a few things that just do not work.


  • Files and Images do not load
  • Nextcloud office does not load
  • Search function does not work and has error (But finds apps)

I reinstalled and reconfigured things differently maybe 6 times and this issue keeps happening.
Each reinstall I tried looking into different things such as: the .htaccess file, php plugins, file and folder permissions, changing data folder location, and many other things.

Is there something I am missing on the hosting?

Please use browser developer tool (in Mozilla Firefox F12) and there Network Analysis. Reload and post errors. Do yo use a filter software, adblocker, …? Can you test with another browser and another computer? Hopefully it is a client problem (e.g. Javascript).

1 Like

Here are screen shots of the F12 errors listed.

And when I scroll down:

I have been using both Chrome and Firefox for testing, and both do the same.

Here is another screen shot of more errors while I was clicking around.

and more details on one of the errors:

Can you test another browser and another pc?

Same issues on Chrome, Firefox, and Brave browsers. No plugins or adblock. Also tried 2 different computers.

Maybe you can deactivte the app dashboard.

Disable Dashboard app and still same issues.

I would focus on NS_BINDING_ABORTED for /remote.php/dav/ URI. From you screenshot it looks like the browser tries to load the resource with plain http (missing lock icon) which fails might be blocked for different reasons.

Please review if you system has correct overwrite* settings in the config.php

Thank you very much for pointing that out @wwe

I added: ‘overwriteprotocol’ => ‘https’,

Now the images load and calendar work.
When I load files, it will list the files now, but it does not open office in the browser.

I did manage to fix Office in browser too by uninstalling all the office apps. Thanks again for your help everyone!

1 Like