Files not Saving when I edit in browser

I’m using NextCloud in Firefox and I’m not an engineer. I don’t know how to access error logs.
When I try to edit a document, it tells me it has saved, but when I close and reopen the document, none of my changes are present.
Some other issues that I suspect are related: There’s also an error message in the spot above the list of files where you can normally add little notes? This just says ‘Failed to Load File’ and some more text which I can’t read because it’s hidden underneath the list of files. I’m also getting an error message when I try to create a new document that says ‘Unable to create new file from template.’
Can anyone help? If you can provide detailed instructions on how to get an error log, I can do that, but I can’t figure out how from my browser.

Please first test your action in another browser (e.g. Chrome or Edge) and on another PC. Maybe it is only a problem of your browser (e.g. with Javascript, ad blocker, cache, settings, …).

I tried in an incognito mode in Firefox and it didn’t work, but still not sure why it used to work in Firefox and no longer works.
EDIT: I tried in Chrome, and the changes save successfully in Chrome :confused: and I’m able to create new blank docs. I’ll mess around in FF and see if that fixes it
Also had my friend try on her computer and it did not work