Files larger than 1mb cannot be uploaded

Hi, all !

After configuring redis in the values.yaml file and updating the configuration via helm update, files larger than 1 mb stopped uploading and the error appears: An unknown error has occurred.
Files smaller than 1mb are loaded without errors. Rolling back the configuration didn’t help.

nginx.ingress.kubernetes.io/proxy-body-size: 1Gi

Nextcloud version (eg, 20.0.5): 25.0.4
PHP version (eg, 7.4): 8.1.17
Helm Version: 3.5.1

The output of your Nextcloud log in Admin > Logging:

Nofing

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

<?php
$CONFIG = array (
  'htaccess.RewriteBase' => '/',
  'overwriteprotocol' => 'https',
  'overwritehost' => 'cloud.exemple.com',
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'apps_paths' =>
  array (
    0 =>
    array (
      'path' => '/var/www/html/apps',
      'url' => '/apps',
      'writable' => false,
    ),
    1 =>
    array (
      'path' => '/var/www/html/custom_apps',
      'url' => '/custom_apps',
      'writable' => true,
    ),
  ),
  'mail_smtpmode' => 'smtp',
  'mail_smtphost' => 'smtp.exemple.com',
  'mail_smtpport' => '465',
  'mail_smtpsecure' => 'ssl',
  'mail_smtpauth' => 1,
  'mail_smtpauthtype' => 'LOGIN',
  'mail_smtpname' => 'nextcloud@exemple.com',
  'mail_smtppassword' => ' ',
  'mail_from_address' => 'nextcloud',
  'mail_domain' => 'exemple.com',
  'passwordsalt' => ' ',
  'secret' => ' ',
  'trusted_domains' =>
  array (
    0 => 'cloud.k8s.exemple.com',
    1 => 'cloud.exemple.com',
    2 => 'nextcloud',
  ),
  'datadirectory' => '/var/www/html/data',
  'dbtype' => 'pgsql',
  'version' => '25.0.4.1',
  'overwrite.cli.url' => 'http://localhost',
  'dbname' => 'nextcloud',
  'dbhost' => 'postgres-cluster.postgres',
  'dbport' => '5432',
  'dbtableprefix' => 'oc_',
  'dbuser' => 'nextcloud',
  'dbpassword' => 'wrqrwqerwqerwqerqwer',
  'instanceid' => 'sdjfhkhjw4t34',
  'installed' => true,
  'ldapIgnoreNamingRules' => false,
  'ldapProviderFactory' => 'OCA\\User_LDAP\\LDAPProviderFactory',
  'maintenance' => false,
  'updater.release.channel' => 'stable',
  'loglevel' => 0,
  'theme' => '',
  'app_install_overwrite' =>
  array (
    0 => 'drawio',
    1 => 'calendar',
    2 => 'groupfolders',
    3 => 'files_mindmap',
    4 => 'ldap_write_support',
    5 => 'ldap_contacts_backend',
    6 => 'ldapcontacts',
    7 => 'documentserver_community',
    8 => 'qownnotesapi',
    9 => 'onlyoffice',
    10 => 'polls',
  ),
  'mail_sendmailmode' => 'smtp',
);

Config php:

root@nextcloud-7b486f7f85-r8phq:/var/www/html/data# cat /usr/local/etc/php/conf.d/*
extension=apcu
apc.enable_cli=1
extension=bcmath.so
extension=exif.so
extension=gd.so
extension=gmp.so
extension=imagick
extension=intl.so
extension=ldap.so
extension=memcached
zend_extension=opcache.so
extension=pcntl.so
extension=pdo_mysql.so
extension=pdo_pgsql.so
extension=redis
extension=sodium
extension=zip.so
memory_limit=${PHP_MEMORY_LIMIT}
upload_max_filesize=${PHP_UPLOAD_LIMIT}
post_max_size=${PHP_UPLOAD_LIMIT}
opcache.enable=1
opcache.interned_strings_buffer=32
opcache.max_accelerated_files=10000
opcache.memory_consumption=128
opcache.save_comments=1
opcache.revalidate_freq=60
opcache.jit=1255
opcache.jit_buffer_size=128M

root@nextcloud-7b486f7f85-r8phq:/var/www/html/data# env |grep PHP
PHP_VERSION=8.1.17
PHP_INI_DIR=/usr/local/etc/php
PHP_MEMORY_LIMIT=512M
PHP_UPLOAD_LIMIT=512M

Output errors in nextcloud.log in /var/www/ or as admin user in top right menu, filtering for errors. Use a pastebin service if necessary.

nofing

Bonjour,
que te retournes les commandes suivantes dans le conteneur avec:

env
PHP_MEMORY_LIMIT=512M
PHP_UPLOAD_LIMIT=512M
php -i | grep max
et
php -i | grep memory

Cordialement,
Pierre

root@nextcloud-7b486f7f85-r8phq:/var/www/html# php -i |grep max
max_execution_time => 0 => 0
max_file_uploads => 20 => 20
max_input_nesting_level => 64 => 64
max_input_time => -1 => -1
max_input_vars => 1000 => 1000
max_multipart_body_parts => -1 => -1
post_max_size => 512M => 512M
upload_max_filesize => 512M => 512M
zend.exception_string_param_max_len => 15 => 15
ldap.max_links => Unlimited => Unlimited

Bonjour,
Côté php, ca semble bon, côté Nginx, c’est pas plutôt le paramètre suivant qu’il faut configurer?
Doc Nginx ici

client_max_body_size 512M;

Je n’ai pas trouvé d’information sur un paramètre “proxy_body_size”, mais je peux me tromper, Je ne suis pas un spécialiste de Nginx.

Cordialement,
Pierre