Files do not auto accept from user to user

Hey all,

Has anyone had trouble with the “accept user and group shares by default” feature in their Nextcloud instance? This is under admin > personal > sharing. (see below screenshot)


I’ve found that this option is not totally working. The group option works, where I’ve created a group of users, shared a file, and confirmed that these users received the shared file automatically on their end.

I have tried to share an image from another Nextcloud account on my network to the admin account (account in question, user to user), and I do not see the image getting auto accepted like it should. Each time, I receive a notification in the bell at the top of my screen (like below) and I have to manually accept.


Does anyone know how to fix this? Is this a bug? I am running Nextcloud 19.0.1 on CentOS 7.

Thank you,

This is solved and working as intended. Files do auto accept when sent user to user, or group to group as mentioned in the first screenshot above. Sharing via federation is where the files are not auto accepted, which isn’t what this feature was saying in the first place.