Filelink for Nextcloud NG not working with custom port


I am trying to set up the Filelink for Nextcloud NG plugin on Thunderbird. My Nextcloud address is like https://server:1223/nextcloud and this works very well with all the other stuff relating to Nextcloud (like for example Thunderbird/Lightning Caldav). If I try to set up the domain, username and a custom port number, I am asked to enter my password. Then, I immediately get a message “An error occured while setting up the account”.

The client is running Thunderbird 52 with with the Filelink for Nextcloud NG extension 1.0 on Windows 10 Pro. The server runs Nextcloud 12 with standard login.

I don’t see anything in the Nextcloud logs. Interestingly, I have an old Thunderbird installation on another machine with a Filelink for Owncloud plugin, and this setup still works without a problem.

@oparoz can you help?

If you don’t get an answer soon, please consider posting this directly in the file-link repo ( and link your report here.

As a workaround I installed “Owncloud for Filelink” Version 1.4 which works well. It does not specifically ask for a port, which could be a problem for users who run Nextcloud in a subdirectory. The problem is described here:

1 Like

First of all, there was a mixup. The Filelink for Nextcloud NG plugin should not have been published. It’s a duplicate.
Secondly, there is a known issue where using a sub-folder is not supported by the new version.

I tried the Filelink for Nextcloud extension too. The first thread I originally wanted to start in this section was about the difference between the two, but this is now answered, thankfully.

Otherwise, as I said in the above Github issue, I zipped the latest Github master branch and installed the *.xpi file manually and it works well now. Hope a new release will be pushed to AMO soon.


I tried but it’s not working yet for me with Nextcloud for Firelink 1.6.