File upload problem with the new ios App (v2.22.1.0)

#1

Starting with latest iOS App update (I’ve got it today) I’m no longer able to upload files to my NextCloud Server from iOS App (v2.22.1.0). The application shows the list of files and the upload progress indicator which then moves to 100% before it gets stuck. No file is removed from the list and the progress indicator remains unchanged at 100% for ever.
My Server version is 13.0.5.

Does anyone have the same problem or is there a solution or work around for this problem?

Update: The above described problem occurs when I try to send the selected pictures to NextCloud directly in Photos on iOS. The upload works if I start the Client App and then select “Upload Pictures or Videos”.

#2

I have also severe problems with the new version (2.22.1.0; server 13.05) of the latest version of the ios app. Uploading hangs each time if there exists a file under the same name. However, the new file gets uploaded in the end, but it will appear with different name (e.g. file1). Uploading worked flawlesly in the previous version (was able to replace an existing file).

There are also problems to the other direction. The “open in” menu is unable to send files from nc to an ios app (nothing gets send) This functionality worked in previous version.

Very frustrating as the previous version worked flawlessly (now the app is basically useless). Am I missing some settings of the new app (changelog mentioned an option to choose replacing of files but I can’t find such setting)? Anyone else experiencing similar problems?

My ios version is 11.4.1. I’ve disabled the ios File app access.

#3

I get a slightly different situation:

  • latest iOS app
  • iPhone X, iOS 11.4.1
  • nextcloud 13.0.5

I:

  • take a photo
  • open Photos
  • select the photo I want to upload
  • use the “Nextcloud” button
  • select the destination directory
  • hit “Upload”

I get the same experience on the iOS device, in that the file appears to upload, but the indicator gets stuck at 100% and does not close. I have to force-kill Photos to close that screen.

However, the file does actually get uploaded, to the directory I have chosen.

#4

I have verified this. In my case the picture finally gets uploaded although the progress gets stuck too. But it’s true only for the first picture in the list if more than one picture was selected for transfer. The remaining pictures are not uploaded.

#5

Upload from other application : the counter is blocked to 100% - this issue is fixed from the next minor version.

Cheers

#6

I can’t get pdfs to my ipad. Open in acrobat results in blank page within “ The operation can’t be completed, com.apple.Fileprovider error -1000” error message. Same thing when I try saving to the Files app.

#7

I have currently the Version 2.22.2.2 of the iOS App but there are still problems:

  • After selection of more than 6 files for upload from iPhone photos only the first one is transferred and then the application terminates and I’m back in the target selection screen.
  • The application is no more able to overwrite a file. The Error message “Error photo/video not found, remove from upload” is shown. For my understanding this message is not really correct, but deselecting the already uploaded file allows me to upload the next single file from selection.
  • Sometimes I select for example 11 Pictures for upload in iPhone Photos, but in the NextCloud App Queue only 10 are listed (and transferred). It happens sometimes and this problem was already there with versions older than 2.22.1.0.
  • If I try to upload Images from within iOS NextCloud app, the client application always converts the image to another resolution. I have already disabled all options which might have something to do with image format conversion but nothing seems to help.

Best regards

#8

I have a very similar problem. I use NC13.0.6, and the latest client for IOS. I have enabled autoupload of pictures, and the client showsx me 700 files to be uploadable. It starts, then there are some movies with 100 MB to 200 MB file size, the upload start, then the client hang up.
I can restart the client, but no problem. All I can do is to abort the specific movie file, or to clear the local cahce, then all uploads are gone, and I need to recreate the “upload all files” which loops until i come back to the error mentioned before.
On my windows system NC works perfectly, on IOS the client seem to be very buggy. Who can help?

#9

This is still an issue on my device. When is it going to be fixed? Also, I still (since version 2.22) can’t download anything to my device (com.apple.Fileprovider error -1000”). Am I the only one with this problem? The App is entirely useless to me for the last month or so. Android and Linux versions work flawlessly.

#10

Just chiming in as well. Haven’t been able to upload files over 100MB for months with autoupload.

#11

Hi ios,

we have recently updated our 500 iPads to Nextcloud client 2.22.6.20 and still have this issue. We are using BookCreator on our iPads and kids are not able to save changes to their files. A new file with an incremental number e.g. Book 1, Book 2 is created every time they want to save changes. We tested the latest owncloud client also and it works as expected, it asks if it should overwrite the existing file or rename the file to be stored.

Cheers

Andreas

#12

Hi Andreas, that is not nice and should of course not happen. But while I’m happy to see Nextcloud used at what I presume is a school, I want to point out that our app is free in part because customers pay us to fix issues like yours.

Please respect that this forum is meant for home users to ask questions, not for organizations with hundreds of users to get free support for a free product. We give very significant discounts to educational organizations and charities as we like to support good causes, but we do have to feed our developers.

Have a good week and hopefully great holidays the coming weeks!

#13

So when can we expect a fix for the iOS app? This functionality has been broken since late iOS version 11 and at least since last summer. I have to upload a “copy” of the file (in my case a keepass database file) and then delete the old one and rename the new one to the original file name.

This upload to Nextcloud with iOS seems to only work with photo or video files. It used to work with any file.

1 Like
#14

+1. This problem has indeed lasted for ages. It is so frustrating when every upload creates a new copy with different file name. From a conceptual point of view, I can’t see this as a feature, since the server takes care of the file versioning. Could you please make fixing this bug a high priority, as it is ruining the whole IOS Nextcloud experience. This is such a fundamental basic feature.

2 Likes
#15

Hi I also just encountered this error on iOS. Photos are “stuck” in transfers and trying to reupload all the time.

1 Like
#16

Still the same problem with the following version

#17

i have the same issue with the actual IOs APP and the Actual Nextcloud

#18

Hi,

I also have the latest NC Server 15.0.2 and the APPversion 2.22.8.20.

I can upload a maximum of 3 files from the IOS Photo App. When I try to upload more it will only sync the first and than close the app.

When I open the NExtcloud app and upload inside the app no issue.

Can someone confirm this?

Thanks S

#19

Try using the beta version in the Testflight app.
If you want to join the discussion on GitHub, check this issue: https://github.com/nextcloud/ios/issues/778

#20

Hi, I would like to give an update, that on ios app 2.23.3.4
NC Server 15.0.4 i don’t have this problem anymore.