File upload freezes/hangs

My issue: When I’m trying to upload a big file to my server transfer freezes very frequently. I tried uploading same file few times and every time it freezes on 57 MB of 1,4 GB upload. Then it hangs for 50-60 seconds and continues uploading again, so it takes 30-40 minutes to upload that file. I tried uploading same file via SFTP and it takes only 3 minutes! At first I tried using APCu for memory caching, but now I’m using Redis. I also configured php.ini for big files upload and increased memory_limit to 512. There are no errors in nextcloud.log or apache2/error.log. My server is on Raspberry Pi 2 / 1 GB RAM.

memory caching /var/www/nextcloud/config/config.php

 'memcache.local' => '\\OC\\Memcache\\Redis',
  'filelocking.enabled' => true,
  'memcache.locking' => '\\OC\\Memcache\\Redis',
  'redis' =>  
  array (
    'host' => '/var/run/redis/redis.sock',
    'port' => 0,
    'dbindex' => 0,
    'password' => '***',

configured settings /etc/php/7.0/apache2/php.ini

max_execution_time = 3600
max_input_time = 3600
memory_limit = 512M

post_max_size = 10G

upload_tmp_dir = /media/usb1/temp/
upload_max_filesize = 10G


What problem can it be?

I tried switching to nginx, but problem persists.

Nextcloud version: 13.0.1
Operating system and version: Ubuntu 16.04
Apache or nginx version: nginx 1.10.3
PHP version: 7.0

Me too, with the very similar config. But it happends when I tried to download a .RAR of 200Mb

Try to increase the log level. Especially for php and the webserver. Normally this should not happen without a log message. Is this a upload via web-interface, webdav or the NC client?

1 Like

In my case that issue happen when I used web-interface, but I tried with my mobile phone with NextCloud official app and the problem persist

Same problem when uploading via NC client or web-interface.
I tried to test Nextcloud on DigitalOcean droplet with 1 GB RAM without editing configs and there was no problem with upload. So then I tried to make same on my Raspberry, but problem still occured during upload.
Now I’m on NextcloudPi, but didn’t get any improvement.
So maybe it’s a problem with Raspberry hardware?

Me too, with a RaspberryPi 2.

This night I’m going to try install in a RPi 3+ and compare the up/down speed. If seems equal, it means that the RPi hardware have a critical bottle neck

1 Like

I have the same problem when uploading through web. Freezes. Shows 40 minutes left forever.

having the same problem: a upload of a few mb freezes with “a few seconds” left.

I’ve found that it only appears when you use Google Chrome. can someone confirm that?


Did you find the solution of this problem.? For some reason whenever i try to upload any file, it always freezes at almost 10MB and resumes after some time on the web interface. On Android application, it drops the upload and i have to manually start it again to get it finished. Please reply me if you have found the solution to this problem.

1 Like

Not for me, happens in Safari as well

@gcuelec I am also getting this at 10MB for a 17MB .jpg file. I shrank the file to 3MB and it went straight through. Seems to hang the browser but if you refresh the screen it clears the hang. I can see this on my RPi2 with the CPU light going on steady until the hang is cleared.
Happens with FF and Chrome browser for me.

To those with problems that the upload freezes some seconds (like 10MB limitations like @gcuelec ) there is already a threath about this.

Uploads "chug" in 10mb segments?

The other thing is the upload speed for example on raspberry pi, that uses only one thread with php-fpm, people say that using php-fpm7.4 has improved the upload speed to 20mb/s or like that. Anyw, i would recommend to use scp to upload your things cause is not limited.
Hope this answer help u all.