File sharing feature disappeared

NC version 18.2
OS: Ubuntu Server 18.04
PHP: 7.2.24
Apache: 2.4.29
mariadb Ver 15.1 Distrib 10.1.44-MariaDB

I can’t share files and folders in the web interface anymore. The feature just isn’t there. Can’t say exactly with what version it disappeared. I noticed first with 18.1 and now have upgraded to 18.2 but no luck.

Can you try:

sudo -u <user_of_apache> php occ app:enable files_sharing

Thanks. I tried that just now. I get “files_sharing enabled” in response, but no difference in the web interface. I will reboot…

…and rebooting didn’t help.

Can you put here youre log?

And do you enable it on:

Which log did you have in mind?
As to enabling it, the link doesn’t work and doesn’t mean anything to me. I have the app File Sharing enabled.

The link have to make youre kan, just copy it and put youre OWN domain in the begin.
Do you check the box in settings to enable sharing?

OK, yes it’s enabled. And old shares do work. It’s just that the option to enable/disable etc doesn’t show anymore. In the file manager it’s there partially - some files and folders have sharing as an option on right-clicking and others don’t.
I wish I could provide a screenshot but given the state of sharing links it is not possible at the moment :slight_smile:.

I have the same issue on Nextcloud 18.0.3 (with latest Apache, PHP, MySQL). I’m also using AWS S3 storage as my primary storage.

File sharing is enabled, and the sharing icon is visible for files and folders, however the sharing panel does not appear at all. Please see attached screenshot.

Old sharing links continue to work though.

The above steps haven’t changed the behavior (toggling enabling of sharing from web control panel and from command line, rebooting, etc.)

Really appreciate the troubleshooting help!

[Screen Shot 2020-04-13 at 11.06.34 AM|690x198](upload://zN


And I think this may be the related issue ticket on Github:

Hey anquietas,

for me, disabling uBlock Origin solved the issue.
Maybe for you, it’s browser-related as well.

1 Like

@Kierrow Thanks. Disabling my ad blocker did the trick.


Same here, disabled all ad blocking softwares and the panel went back. Thanks !

1 Like