File locked and deleted after Upload

When I upload a 4GB ISO file I get the message “File locked” after upload and the file itself is deleted. Any ideas whats going on here?

Nextcloud version: 12.0.5
Operating system and version: CentOS 7.4
Apache or nginx version: Apache 2.4.6
PHP version: 7.1.13 (Mod-PHP)

Log:
Fatal webdav OCA\DAV\Connector\Sabre\Exception\FileLocked: “V834394-01.iso” is locked
/var/www/clients/client0/web4/web/nextcloud/apps/dav/lib/Connector/Sabre/Directory.php - line 151: OCA\DAV\Connector\Sabre\File->put(Resource id #19)
/var/www/clients/client0/web4/web/nextcloud/3rdparty/sabre/dav/lib/DAV/Server.php - line 1096: OCA\DAV\Connector\Sabre\Directory->createFile(‘Oracle_Linux_7_…’, Resource id #19)
/var/www/clients/client0/web4/web/nextcloud/3rdparty/sabre/dav/lib/DAV/CorePlugin.php - line 525: Sabre\DAV\Server->createFile(‘Oracle_Linux_7_…’, Resource id #19, NULL)
[internal function] Sabre\DAV\CorePlugin->httpPut(Object(Sabre\HTTP\Request), Object(Sabre\HTTP\Response))
/var/www/clients/client0/web4/web/nextcloud/3rdparty/sabre/event/lib/EventEmitterTrait.php - line 105: call_user_func_array(Array, Array)
/var/www/clients/client0/web4/web/nextcloud/3rdparty/sabre/dav/lib/DAV/Server.php - line 479: Sabre\Event\EventEmitter->emit(‘method PUT’, Array)
/var/www/clients/client0/web4/web/nextcloud/3rdparty/sabre/dav/lib/DAV/Server.php - line 254: Sabre\DAV\Server->invokeMethod(Object(Sabre\HTTP\Request), Object(Sabre\HTTP\Response))
/var/www/clients/client0/web4/web/nextcloud/apps/dav/appinfo/v1/webdav.php - line 76: Sabre\DAV\Server->exec()
/var/www/clients/client0/web4/web/nextcloud/remote.php - line 162: require_once(’/var/www/client…’)
{main}

Please provide more information, are you using the client or a native webdav connection? Do you use redis as locking cache (really recommended if you can install it on your system).

I was using a native webdav connection (firefox browser). Redis Version
is 4.0.7.

When I remove the following lines from config.php I can upload those ISO files again:
‘filelocking.enabled’ => true,
‘memcache.locking’ => ‘\OC\Memcache\Redis’,

Any ideas?

With redis it should be much better normally. And the version is quite new. No idea, perhaps open an issue on github.com/nextcloud/server/issues and provide more details about your server configuration (webserver, php).