Festplatte im neuen Rechner - Fritzbox findet NC nicht

Hallo zusammen,
die funktionierende NextCloud-HDD aus dem alten Rechner im neuen Rechner eingebaut führt dazu, dass die Fritzbox den neuen Rechner nicht findet. Wenn die NextCloud-HDD zurück in den alten Rechner wandert, wird der natürlich gefunden und alles läuft einwandfrei (außer Apache neu starten, aber dann läuft es auch). Die Gegenprobe mit einer anderen HDD im neuen Rechner ergibt, dass der dann von der Fritzbox gesehen wird, nur eben mit der NextCloud-HDD nicht. Die Fritzbox lässt zwar bei der NextCloud-HDD im neuen Rechner zu, dass man manuell MAC-Adresse und fixe IP-Zuweisung sowie Portfreigabe einträgt, aber die NextCloud-Seite bleibt trotzdem innerhalb und außerhalb des heimischen Netzes unerreichbar. Also jede Kombination funktioniert tadellos, bis auf die gewünschte Kombination NextCloud-HDD im neuen Rechner.
Wo könnte der Fehler liegen?

wie öfter mal, gibt es hier einfach nicht genug Infos.
Eine wichtige Info wäre gewesen: Was ist auf der “alten” NC-HDD? Nur die Daten oder das ganze System?

Eine weitere Info: baust du die “alte NC-HDD” als zusätzliche Datenplatte ein oder soll das die neue Systemplatte beim neuen Rechner sein?

Falls das die Systemplatte beim neuen Rechner sein soll: DIr ist bewusst, dass sogar Windoofs-Rechner nicht gut umgehen, wenn man ihnen auf diese Brechstangen-Art ein neues (bzw altes) System unterschiebt?

Wenn die HDD das komplette System enthält, überprüfe die Netzwerkeinstellungen im neuen Rechner. In vielen Fällen gilt “Andere Netzwerkkarte, andere Netzwerkeinstellungen.”

Auf der neuen HDD steckt das ganze System (NC26; Ubuntu Server), ohne jeglichen Container- oder VM-Schnickschnack direkt auf’s Blech installiert. Die Fritzbox kommuniziert doch allein über die Netzwerkkarte, und die findet sie, wenn ich x-beliebige andere HDDs einbaue - nur eben nicht mit der NC-HDD. Zur Gegenprobe habe ich auch die Netzwerkkarte aus dem alten Rechner in den neuen eingebaut - die wird dann ebenfalls immer gefunden, außer halt mit der NC-HDD. Also müsste der Fehler auf dieser liegen - aber im alten Rechner läuft alles tadellos.
Der Server ist headless, also kann ich auch mit der NC-HDD im neuen Rechner schlecht etwas abfragen, weil ohne Kommunikation zwischen Rechner und Fritzbox keine ssh-Verbindung aufzubauen ist. Oder gibt es Alternativen?

Bitte prüfe die Netzwerkeinstellungen in Ubuntu. REs ist durchaos möglich, dass im neuen Rechner die Netzwerkkarte eine andere bezeichnung hat und somit zwei Einträge existieren, von der die neue - wenn überhaupt - über DHCP konfiguriert ist und somit eine andere IP-Adresse hat, als im alten Rechner.

Beispiel:

Seltsam: auf rfkill list all folgt keine Ausgabe. Auch sudo dmesg | grep iwl liefert keine Ausgabe.
ifconfig -a liefert enp3s0 als Ausgabe. Nach ifconfig enp3so up wird immerhin der Rechner in der Fritzbox wieder sichtbar, erhält aber keine IPV4-IP trotz DHCP. Das ließe ja Vermutungen über die Netzwerkkarte zu - doch mit einer schnöden Ubuntu-Desktop-HDD läuft die Karte auch tadellos.

Vermutung: Der neue Rechner hat eine andere Mac-Adresse. Du musst dein Portforwarding im Router neu aufsetzen (dort ist die alte Mac „verankert“).

Der neue Rechner hat mit eigenem, neuem Netzwerkadapter automatisch eine andere MAC-Adresse. Das lässt sich alles problemlos mit derselben Festplatte in einem dritten, zum alten Rechner baugleichen Rechner konfigurieren und läuft.
lshw -class network hat immerhin angezeigt: network disabled. Nach ifconfig enp3s0 up läuft zwar die Netzwerkverbindung, aber nur IPv6, nicht IPv4. Diese lässt sich zwischen neuem Rechner und Fritzbox nicht herstellen. Damit gelingt dann auch keine erfolgreiche Portfreigabe für IPv4.

Gelöst:
ifconfig enp3s0 up stellt die Verbindung zur Fitzbox wieder her, und
dhclient enp3s0 hat die IPv4-Verbindung wieder möglich gemacht.