Fehlermeldung: Internal Server Error

Hallöchen zusammen…
Seit einigen Tagen kann ich nicht mehr auf meinen Nextcloud Server zugreifen.
Bei mir läuft Nextcloud auf dem Raspberry Pi 4.
In der Fehlermeldung steht, ich solle im Serverlog nachschauen.
In welche Datei soll ich genau schauen?

Bis zur Anmeldemaske komme ich noch…
Danach kommt Internal Server Error

in /var/www/nextcloud/data/nextcloud.log nachschauen oder in den jeweiligen Serverlogs von Apache oder NGINX.

Vielen Dank f√ľr die schnelle Antwort. :slight_smile:
Im nextcloud.log ist leider nichts zu finden… Und aus dem Apache2 log werde ich nicht recht schlau…

Könnt ihr mir vielleicht helfen?

was f√ľr eine art ssl-zertifikat hast du? (ich bezweifle aber, dass das hier zu deinem internen serverfehler geh√∂rt)

Ich habe ein letsencrypt ssl Zertifikat.
Das habe ich auch schon erneuert…

poste doch bitte mal deine config.php (Achtung! Sensible Daten bitte unkenntlich machen!)

Sehr gern. Danke f√ľr eure Hilfe‚Ķ :slight_smile:

root@nextcloudpi:/var/www/nextcloud/config# cat config.php
<?php
$CONFIG = array (
 'passwordsalt' => '***',
 'secret' => '***',
 'trusted_domains' =>
 array (
0 => 'localhost',
11 => '2003:ce:e717:5c65:4f0e:2cbf:f865:f5b6',
1 => '192.168.3.100',
5 => 'nextcloudpi.local',
7 => 'nextcloudpi',
8 => 'nextcloudpi.lan',
20 => 'nextcloudme.ddns.net',
21 => '192.168.3.1',
22 => '192.168.2.118',
12 => 'nextcloudme.ddns.net',
13 => 'nextcloudme.duckdns.org',
),
'datadirectory' => '/media/cloudDrive',
'dbtype' => 'mysql',
'version' => '19.0.3.1',
'overwrite.cli.url' => 'https://nextcloudme.ddns.net/',
'dbname' => 'nextcloud',
'dbhost' => 'localhost',
'dbport' => '',
'dbtableprefix' => 'oc_',
'mysql.utf8mb4' => true,
'dbuser' => '***',
'dbpassword' => '***',
'installed' => true,
'instanceid' => 'oca7xifcre5f',
'memcache.local' => '\\OC\\Memcache\\Redis',
'memcache.locking' => '\\OC\\Memcache\\Redis',
'redis' =>
array (
'host' => '/var/run/redis/redis.sock',
'port' => 0,
'timeout' => 0.0,
'password' => '***',
),
'tempdirectory' => '/media/cloudDrive/tmp',
'mail_smtpmode' => 'smtp',
'mail_domain' => 'gmail.com',
'preview_max_x' => '2048',
'preview_max_y' => '2048',
'jpeg_quality' => '60',
'overwriteprotocol' => 'https',
'maintenance' => false,
'logfile' => '/media/cloudDrive/nextcloud.log',
'mail_sendmailmode' => 'smtp',
'mail_smtpsecure' => 'ssl',
'mail_smtphost' => 'smtp.gmail.com',
'mail_smtpport' => '465',
'mail_from_address' => 'nextcloudme',
'mail_smtpauth' => 1,
'mail_smtpname' => '***@gmail.com',
'mail_smtppassword' => '***',
'mail_smtpauthtype' => 'LOGIN',
'loglevel' => 2,
'theme' => '',
);

das ist echt leer?

braucht man keinen port mehr?

ich sehe, du hast ncp installiert‚Ķ w√ľrdest du dann bitte auch einen screenshot von der webGUI-System-Info machen? da steht zb welche dienste laufen und welche nicht‚Ķ

Du hast ziemlich viele Trusted Domains :smiley:

Mach dort mal ein einfaches \ raus :wink:

1 Like

Oh jeh…
Der log ist voll…
Mit dem dbport weiß ich nicht so recht bescheid… Ich habe an der config nichts geändert…
Und beim Inhalt des Log’s sehe ich nicht ganz durch… :expressionless:

deine Data-Disk scheint randvoll zu sein… Das könnte eine der Ursachen sein. :thinking:

Danke… Das wars… :monkey_face:
Irgendwas scheint mit den Backups falsch zu laufen. :expressionless:

Darf ich schnell noch eine andere Sache dazwischen schmeißen?

Ich benutze f√ľr meinen Server den Raspberry Pi 4
Leider werden aber nicht mehr als 600 und ein paar zerquetschte an RAM benutzt… Kann ich das ändern? Nextcloud soll ruhig mehr RAM benutzen… :relieved:

Dazu gibts schon einen Thread, bitte such dir den raus und informier dich dort.

2 Likes

… das was @FadeFx sagt UND:

bitte generell keine anderen Fragen stellen, die ein neues Problem betreffen, nachdem ein Thread gelöst wurde. Lieber einen neuen aufmachen.

2 Likes

oh je, das ist normal je nach loglevel, welche error erscheinen dort?
Oh sorry, die anderen Beiträge kamen jetzt erst nach :wink: (jetzt erst gesehen)