Fehler nach Update auf 12.0.4 - Umleitungsfehler

Hallo!

Folgender Fehler wird mir grade nach dem Updatevon 12.0.3 auf 12.0.4 angezeigt:

Fatal error: require(): Failed opening required ‘/homepages/44/d652420063/htdocs/nextcloud/3rdparty/composer/…/guzzlehttp/promises/src/functions_include.php’ (include_path=’/homepages/44/d652420063/htdocs/nextcloud/3rdparty/pear/console_getopt:/homepages/44/d652420063/htdocs/nextcloud/3rdparty/pear/pear_exception:/homepages/44/d652420063/htdocs/nextcloud/3rdparty/pear/archive_tar:/homepages/44/d652420063/htdocs/nextcloud/3rdparty/pear/pear-core-minimal/src:/homepages/44/d652420063/htdocs/nextcloud/apps’) in /homepages/44/d652420063/htdocs/nextcloud/3rdparty/composer/autoload_real.php on line 61

Was kann ich tun?
Grüße! Simon

Dir fehlen Dateien. Das Archiv solltest du erst auf dem server entpacken.

Ich habe nun die Datei “autoload_real.php” neu hochgeladen und der Fehler ist weg - dafür ist ein neuer da:

Nach der Loginseite erscheint die Fehlermeldung:

Fehler: Umleitungsfehler

Die aufgerufene Website leitet die Anfrage so um, dass sie nie beendet werden kann.

Dieses Problem kann manchmal auftreten, wenn Cookies deaktiviert oder abgelehnt werden.

Ich finde auch dort den Fehler nicht… kann jemand helfen?
Grüße aus Hamburg: Simon

Logs anschauen. Hast du die Berechtigungen angepasst nach dem hochladen?

Nein, habe ich nicht.
In den Logs ist nichts außergewöhnliches zu finden. Dort ist das Update
erfolgreich abgeschlossen. Ärgerlich.
Gibt’s noch etwas was ich tun kann bevor ich eine neue Installation
erstelle?

Du kannst ein manuelles Upgrade machen (der automatische Updater lädt sich die Dateien, entpackt sie, …), eventuell klappt da ein Schritt nicht oder wird von Sicherheitseinstellungen verhindert (oder die Skriptlaufzeit ist einfach zu kurz).

https://docs.nextcloud.com/server/12/admin_manual/maintenance/manual_upgrade.html
Falls du die Möglichkeit hast, das Update über einen SSH-Zugang anzustoßen (keine Laufzeit-Limits) wäre das besser.