Fatal Error Upgrading to Nextcloud 12

Hello Community,

i need your help. When i want to Upgrade from Nextcloud 11 to Nextcloud 12 i get this error message:

{“reqId”:“mi1tnDmgDwtJzC4tyfTO”,“remoteAddr”:“IP-Adress”,“app”:“user_ldap”,“message”:“Configuration Error (prefix ): login filter does not contain %uid place holder.”,“level”:2,“time”:“2017-03-21T10:32:07+00:00”,“method”:“GET”,“url”:"/nextcloud/ocs/v2.php/apps/notifications/api/v2/notifications",“user”:“USERNAME”,“version”:“”}

I dont find any solution, can you please help me. I need this going my organisation need the cloud working :-/.

Thank you so much.

@blizzz Any idea?

I’m just guessing here, but the error seems to refer, that at the end of your LDAP-Configuration should be the %uid placeholder for samaccountname (like in the picture).

Thank you for your answer, but i dont understand how i can change this. Can you tell me the path?

I cant access the Web Interface, but the Desktop App works perfect :smiley:

Sorry, searched around a little and found nothing… i’ve always used the web interface.
Are there reasons that the interface does not work?

i dont believe so, the nextcloud desktop app is always for file sharing. But this have nothing to do with the error. Damn i find nothing too. And now:pensive:?

@Timo_Ksub like Michael_C said. Go to the LDAP Configuraiton and check the Login Attribute tab. The resulting filter should containe the %uid placeholder. But, do you use the LDAP backend at all, actually?

Iam sorry i can go to the Login Attribute tab, cause the web server give me this error message:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator at E-MAIL Adress to inform them of the time this error occurred, and the actions you performed just before this error.

More information about this error may be available in the server error log.
Apache/2.4.18 (Ubuntu) Server at cloud.binarytec.net Port 443

Yes before i do the update, i used the ldap. And it works perfectly.

I had the same error while having problems with my ldap…
do you have a backup from before the update? @blizzz could it help to delete the user_ldap folder in the apps directory?

Technically the error appears when the first checkbox in the screenshot above is unchecked, this will remove the %uid placeholder from the LDAP Filter… learned the hard way.

Omg, really? Damn i not sure that i activated this checkbox. How i can bring up the webinterface to do so?

Good question, i’ve gone back to an earlier backup… because i dont know how to configure the LDAP without web-interface. :disappointed:

@Timo_Ksub then on the command line, go to the Nextcloud root and check your LDAP config:

sudo -u www-data php occ ldap:show-config

This will give you a list will all LDAP configs and its settings. Including the login filter.

You can try to fix the login filter and set it using sudo -u www-data php occ ldap:set-config $CONFIGID ldapLoginFilter $NEWFILTER

  • as $CONFIGID use what is witten on the table next to configuration, e.g. “s01”. If it is empty, write “”
  • as $NEWFILTER enter a valid one containing the placeholder and being mapped to the desired login attribute.

If you have no idea about that latter, disable the configuration via

sudo -u www-data php occ ldap:set-config $CONFIGID ldapConfigurationActive 0

login as local user with admin privileges and fix the settings via web GUI.

Thank you very much for your help:yum:, but i didnt work:sleepy:. There was the same problem as before.

I restore an backup, but i want to fix this. My configuration for ldap looks like this:

What i can do to upgrade to nextcloud 12?!

Mh, looks ok to me. Maybe try to uncheck the E-Mail checkbox and run the update with the occ upgrade function in the command line.
Or disable the LDAP-App before upgrading… maybe something is acting up in there.


i did disable the LDAP App without sucess. Do you have any other ideas?

I’m afraid no…
Does the same error appear again?

Yes, the same.
Iam not a friend of install a new NC Server :frowning: