Failure to upgrade to 13.0.4

Nextcloud version: 13.0.4
Operating system and version: Debian Jessy
Apache or nginx version nginx 1.10.3
PHP version: PHP 7.0.27-0+deb9u1

The issue you are facing:

after upgrade nextcloud does not work, following error is here:

PHP Warning: require(/var/www/websites/website/3rdparty/composer/…/guzzlehttp/promises/src/functions_include.php): failed to open stream: No such file or directory in /var/www/websites/website/3rdparty/composer/autoload_real.php on line 61
PHP Fatal error: require(): Failed opening required ‘/var/www/websites/website/3rdparty/composer/…/guzzlehttp/promises/src/functions_include.php’ (include_path=’/var/www/websites/website/3rdparty/pear/console_getopt:/var/www/websites/website/3rdparty/pear/pear_exception:/var/www/websites/website/3rdparty/pear/pear-core-minimal/src:/var/www/websites/website/3rdparty/pear/archive_tar:/var/www/websites/website/apps’) in /var/www/websites/website/3rdparty/composer/autoload_real.php on line 61

Is this the first time you’ve seen this error? Yes

Steps to replicate it:

  1. upgrade from previous to 13.0.4. version

The output of your Nextcloud log in Admin > Logging:

Cannot login there

Please how can I either downgrade?

Or to disable some applications if applications are causing it?

How did you upgrade? At which step of the update did this happen?

Previous version, do you mean NC 12? Or 13.0.2?

I have solved my problem by manually downloading and going through upgrade process.

Then I found out that only 258 megabytes were left on hard disk.

My guess is that the upgrade could not be finished due to low disk space. Maybe, I don’t know, but maybe the upgrade process is copying all files, or making a copy and if there is not enough free space, there can be a problem.

However, even such situation shall be prevented by making a check in the upgrade process, so that it does not happen. If that was the case.

Indeed, can you open a feature request on the updater-app-repo: https://github.com/nextcloud/updater/issues

I have the same problem.
I have upgraded with the updater app.

Then I have received error 500. My problem is not solved yet, I will try with the manual upgrade which is mentioned by rcdrun

https://docs.nextcloud.com/server/11/admin_manual/maintenance/manual_upgrade.html

I have followed the above procedure. And of course I moved my data directory to new nextcloud version, and config.php and apps I copied.

The

sudo -u www-data php occ upgrade

did not work as expected, there was again some problems shown, later somehow it worked, I don’t remember what I did.

On web page, I could see the install process wanting to continue some upgrade, and it worked.