Failed update to v10


I tried to update manually from 9.0.53 to 10, but got errors.

PHP 5.4.

File permission is : www-data:www-data

Preparing update

Set log level to debug
Turned on maintenance mode
Checking whether the database schema can be updated (this can take a long time depending on the database size)
[1 / 27]: Checking table oc_appconfig
[2 / 27]: Checking table oc_storages
[3 / 27]: Checking table oc_mounts
[4 / 27]: Checking table oc_mimetypes
[5 / 27]: Checking table oc_filecache
[6 / 27]: Checking table oc_group_user
[7 / 27]: Checking table oc_group_admin
[8 / 27]: Checking table oc_groups
[9 / 27]: Checking table oc_preferences
[10 / 27]: Checking table oc_properties
[11 / 27]: Checking table oc_share
[12 / 27]: Checking table oc_jobs
[13 / 27]: Checking table oc_users
[14 / 27]: Checking table oc_authtoken
[15 / 27]: Checking table oc_bruteforce_attempts
[16 / 27]: Checking table oc_vcategory
[17 / 27]: Checking table oc_vcategory_to_object
[18 / 27]: Checking table oc_systemtag
[19 / 27]: Checking table oc_systemtag_object_mapping
[20 / 27]: Checking table oc_systemtag_group
[21 / 27]: Checking table oc_privatedata
[22 / 27]: Checking table oc_file_locks
[23 / 27]: Checking table oc_comments
[24 / 27]: Checking table oc_comments_read_markers
[25 / 27]: Checking table oc_credentials
[26 / 27]: Checking table oc_admin_sections
[27 / 27]: Checking table oc_admin_settings
Checked database schema update
Checking updates of apps
Checked database schema update for apps
Updating database schema
Updated database
Exception: files can’t be disabled.

I need a solution ASAP, please!

Did you delete all old code? Only keep data/ and config/ directory, delete all code and place code of NC 10. Then run upgrade.

How did you update?

Without knowing what you did we’ll have difficulty telling you why it went wrong.

Also please have a look at your apache error log and the nextcloud.log file in your data directory, for any hints.

The Updater is not working in 9.0.53, so I updated it manually.
I copied the /config , /data, /apps, to the v10.
Is that how it should be done?

I’m running Ngnix.


basically sounds good.

so please check your data/nextcloud.log for errors

Since I’m on 9.0.53, why we can’t use the Updater yet?
I tried the update script for last version, and this version, but it didn’t work.

Here’s the log:

{"reqId":"YG9G9QjWYPyOS3AyCeYV","remoteAddr":"::ffff:","app":"PHP","message":"Call to undefined method OCA\\Federation\\AppInfo\\Application::registerSettin$

{“reqId”:“b9h9k7f/C8txPveSpigw”,“remoteAddr”:"::ffff:",“app”:“core”,“message”:“starting upgrade from to”,“level”:0,“time”:“2016-08-26T10:$
{“reqId”:“b9h9k7f/C8txPveSpigw”,“remoteAddr”:”::ffff:",“app”:“core”,“message”:“Exception: {“Exception”:“Exception”,“Message”:“files can’t be disable$
{“reqId”:“gM/yPnbh1hyN4zbduzSE”,“remoteAddr”:”::ffff:”,“app”:“PHP”,“message”:“Call to undefined method OCA\Federation\AppInfo\Application::registerSetti$
{“reqId”:“GqFYOS2irJP6niNBwcBE”,“remoteAddr”:”::ffff:",“app”:“core”,“message”:“starting upgrade from to”,“level”:0,“time”:“2016-08-26T10:0$
{“reqId”:“GqFYOS2irJP6niNBwcBE”,“remoteAddr”:”::ffff:",“app”:“core”,“message”:"Exception: {“Exception”:“Exception”,“Message”:"files can’t be disabled$

I just figured it out.
I got NC10 installed successfully by NOT copy the old Apps folder to NC10.
Then after the upgrade, copy the old Apps folder to NC10.

However, I now have different errors before the installation and after in the error log.

It took two attemps for the instalaltion to be successful.

1st Atttempt error:
RedisException: protocol error, got 'k' as reply type byte

2nd attempt, after the installation:

{"reqId":"Lp9956yY5qZqiUcUqaAV","remoteAddr":"::ffff:","app":"index","message":"Exception: {\"Exception\":\"OC\\\\NeedsUpdateException\",\"Message\":\"\",\"$

{“reqId”:“4S49onMkZgNLiueDHDYz”,“remoteAddr”:"::ffff:",“app”:“core”,“message”:“starting upgrade from to”,“level”:0,“time”:“2016-08-26T10:1$
{“reqId”:“4S49onMkZgNLiueDHDYz”,“remoteAddr”:”::ffff:",“app”:“core”,“message”:“Exception: {“Exception”:“RedisException”,“Message”:“protocol error, go$
{“reqId”:“5esAcTe369zbR7si9sxO”,“remoteAddr”:”::ffff:”,“app”:“index”,“message”:“Exception: {“Exception”:“OC\\NeedsUpdateException”,“Message”:”","$
{“reqId”:“fqTuF6KQSt8sNcm1Up7v”,“remoteAddr”:"::ffff:",“app”:“core”,“message”:“starting upgrade from to”,“level”:0,“time”:"2016-08-26T10:1$

Error	PHP	stream_get_contents() expects parameter 2 to be long, string given at /media/54bf67db-da31-4c50-bb3c-27140944b223/www/nextcloud/3rdparty/sabre/http/lib/Message.php#81

I notice the Announcement Center is incompatible with NC10.