Failed to load Collabora Online / Error: Could not find urlsrc in WOPI

I have installed Nextcloud (Version 21.0.1; Server-OS: Linux 5.4.0-70-generic x86_64; PHP 7.4; Maria-DB 10.5.6; Provider: all-inkl.de) and activated the “Hub package” (Calendar, Collabora Online (4.0.4), Collabora Online - Built-CODE Server (6.4.705), Contact, Mail, Talk - all Apps are up to date).

Settings → Overview:
“No memory cache has been configured.” (shouldnt be relevant: one admin, two test users)

Settings → Administration → Collabora Online:
Collabora Online server is reachable.
Use the built-in CODE - Collabora Online Development Edition.

Opening, modifying and saving a *.md document: works fine.

Opening a *.odt document: “Failed to load Collabora Online - Please try again later” since 48h.

Setting → Administration → Logging:

[richdocuments] Error: Exception: Could not find urlsrc in WOPI at <<closure>>

0. /www/htdocs/XXXXXXXX/nc.XXXX.de/apps/richdocuments/lib/TokenManager.php line 217
   OCA\Richdocuments\WOPI\Parser->getUrlSrc("application/vnd.oasis.opendocument.text")
1. /www/htdocs/XXXXXXXX/nc.XXXX.de/apps/richdocuments/lib/Controller/DocumentController.php line 256
   OCA\Richdocuments\TokenManager->getToken("*** sensitive parameters replaced ***")
2. /www/htdocs/XXXXXXXX/nc.XXXX.de/lib/private/AppFramework/Http/Dispatcher.php line 218
   OCA\Richdocuments\Controller\DocumentController->index("*** sensitive parameter replaced ***", null)
3. /www/htdocs/XXXXXXXX/nc.XXXX.de/lib/private/AppFramework/Http/Dispatcher.php line 127
   OC\AppFramework\Http\Dispatcher->executeController(OCA\Richdocument ... {}, "index")
4. /www/htdocs/XXXXXXXX/nc.XXXX.de/lib/private/AppFramework/App.php line 157
   OC\AppFramework\Http\Dispatcher->dispatch(OCA\Richdocument ... {}, "index")
5. /www/htdocs/XXXXXXXX/nc.XXXX.de/lib/private/Route/Router.php line 302
   OC\AppFramework\App::main("OCA\\Richdocume ... r", "index", OC\AppFramework\ ... {}, {_route: "richdocuments.document.index"})
6. /www/htdocs/XXXXXXXX/nc.XXXX.de/lib/base.php line 993
   OC\Route\Router->match("/apps/richdocuments/index")
7. /www/htdocs/XXXXXXXX/nc.XXXX.de/index.php line 37
   OC::handleRequest()

GET /index.php/apps/richdocuments/index?fileId=147&requesttoken=uWq9WCONXcRF7b3N%2F%2Bu%2FPtJlHjzjT1EOfoBMaWo7dJQ%3D%3A%2FEHaMlv%2FCJccjtSnrJjKeaAoX0vWFRV7JOkdWDh0IMA%3D
from XX.XX.XXX.XXX by XXXXXXXXXXXX at 2021-04-23T13:45:13+00:00

It is not clear to me where to start troubleshooting. Any hints?

(Edit: Moved posting to “support”)

1 Like

Hi
Same problem here :fearful:
Fresh install ubuntu 20.04
Snap Nextcloud 20.0.0.9
Collabora online 3.7.19
Code server 6.4.705
Help please !
Best

1 Like

Same issue here

NC 21.0.2

Cytat
GuzzleHttp\Exception\ClientException: Client error: GET https://cloud.windprog.pl/apps/richdocumentscode/proxy.php?req=/hosting/discovery resulted in a 404 Not Found response: 404 Not Found

404 Not Found


nginx/1. (truncated…)

  1. /config/www/nextcloud/3rdparty/guzzlehttp/guzzle/src/Middleware.php - line 69:GuzzleHttp\Exception\RequestException::create()
  2. /config/www/nextcloud/3rdparty/guzzlehttp/promises/src/Promise.php - line 204:GuzzleHttp\Middleware::GuzzleHttp{closure}("*** sensiti … *")
  3. /config/www/nextcloud/3rdparty/guzzlehttp/promises/src/Promise.php - line 153:GuzzleHttp\Promise\Promise::callHandler()
  4. /config/www/nextcloud/3rdparty/guzzlehttp/promises/src/TaskQueue.php - line 48:GuzzleHttp\Promise\Promise::GuzzleHttp\Promise{closure}("*** sensiti … *")
  5. /config/www/nextcloud/3rdparty/guzzlehttp/promises/src/Promise.php - line 248:GuzzleHttp\Promise\TaskQueue->run()
  6. /config/www/nextcloud/3rdparty/guzzlehttp/promises/src/Promise.php - line 224:GuzzleHttp\Promise\Promise->invokeWaitFn()
  7. /config/www/nextcloud/3rdparty/guzzlehttp/promises/src/Promise.php - line 269:GuzzleHttp\Promise\Promise->waitIfPending()
  8. /config/www/nextcloud/3rdparty/guzzlehttp/promises/src/Promise.php - line 226:GuzzleHttp\Promise\Promise->invokeWaitList()
  9. /config/www/nextcloud/3rdparty/guzzlehttp/promises/src/Promise.php - line 62:GuzzleHttp\Promise\Promise->waitIfPending()
  10. /config/www/nextcloud/3rdparty/guzzlehttp/guzzle/src/Client.php - line 187:GuzzleHttp\Promise\Promise->wait()
  11. /config/www/nextcloud/lib/private/Http/Client/Client.php - line 236:GuzzleHttp\Client->request()
  12. /config/www/nextcloud/apps/richdocuments/lib/WOPI/DiscoveryManager.php - line 84:OC\Http\Client\Client->get()
  13. /config/www/nextcloud/apps/richdocuments/lib/WOPI/DiscoveryManager.php - line 56:OCA\Richdocuments\WOPI\DiscoveryManager->fetchFromRemote()
  14. /config/www/nextcloud/apps/richdocuments/lib/WOPI/Parser.php - line 41:OCA\Richdocuments\WOPI\DiscoveryManager->get()
  15. /config/www/nextcloud/apps/richdocuments/lib/TokenManager.php - line 208:OCA\Richdocuments\WOPI\Parser->getUrlSrc()
  16. /config/www/nextcloud/apps/richdocuments/lib/Controller/DocumentController.php - line 226:OCA\Richdocuments\TokenManager->getToken("*** sensiti … *")
  17. /config/www/nextcloud/lib/private/AppFramework/Http/Dispatcher.php - line 218:OCA\Richdocuments\Controller\DocumentController->index()
  18. /config/www/nextcloud/lib/private/AppFramework/Http/Dispatcher.php - line 127:OC\AppFramework\Http\Dispatcher->executeController()
  19. /config/www/nextcloud/lib/private/AppFramework/App.php - line 157:OC\AppFramework\Http\Dispatcher->dispatch()
  20. /config/www/nextcloud/lib/private/Route/Router.php - line 302:OC\AppFramework\App::main()
  21. /config/www/nextcloud/lib/base.php - line 993:OC\Route\Router->match()
  22. /config/www/nextcloud/index.php - line 37:OC::handleRequest()

Same here on 21.0.2 Docker

There seems to be an issue with the Code server version, try to manually downgrade it to version 6.4.608:
https://github.com/CollaboraOnline/richdocumentscode/releases/download/6.4.608/richdocumentscode.tar.gz

make sure the WOPI app is enabled
Disable and remove current CODE-SERVER on GUI admin > apps where it can be disabled
sudo -i
cd /var/snap/nextcloud/current/nextcloud/extra-apps
sudo wget https://github.com/CollaboraOnline/richdocumentscode/releases/download/6.4.608/richdocumentscode.tar.gz
sudo rm -r richdocumentscode
sudo tar -xvf richdocumentscode.tar.gz
sudo rm richdocumentscode.tar.gz
Go to GUI and enable admin > apps where it can be enabled

Thank you @sivehost, the problem seems half solved …


Ubuntu 20.04.2 LTS fresh new install (snap nextcloud stable 21.0.1.

Collabora is loading when i try to access to the document by clicking here (see attached).

When i click on the name of the document i have a new error

[wopi] Error: OCP\Http\Client\LocalServerException: Could not detect any host at <>

  1. /snap/nextcloud/28088/htdocs/lib/private/Http/Client/Client.php line 235
    OC\Http\Client\Client->preventLocalAddress("/hosting/discovery", {timeout: 5})
  2. /var/snap/nextcloud/28088/nextcloud/extra-apps/wopi/lib/WOPI/DiscoveryManager.php line 106
    OC\Http\Client\Client->get("/hosting/discovery", {timeout: 5})
  3. /var/snap/nextcloud/28088/nextcloud/extra-apps/wopi/lib/WOPI/DiscoveryManager.php line 78
    OCA\Wopi\WOPI\DiscoveryManager->fetchFromRemote()
  4. /var/snap/nextcloud/28088/nextcloud/extra-apps/wopi/lib/WOPI/Parser.php line 74
    OCA\Wopi\WOPI\DiscoveryManager->get()
  5. /var/snap/nextcloud/28088/nextcloud/extra-apps/wopi/lib/WOPI/Parser.php line 97
    OCA\Wopi\WOPI\Parser->getParsed()
  6. /var/snap/nextcloud/28088/nextcloud/extra-apps/wopi/lib/TokenManager.php line 196
    OCA\Wopi\WOPI\Parser->getUrlSrcForFile(OC\Files\Node\File {}, true)
  7. /var/snap/nextcloud/28088/nextcloud/extra-apps/wopi/lib/Controller/DocumentController.php line 236
    OCA\Wopi\TokenManager->getToken("*** sensitive parameters replaced ***")
  8. /snap/nextcloud/28088/htdocs/lib/private/AppFramework/Http/Dispatcher.php line 218
    OCA\Wopi\Controller\DocumentController->index(“11_ocqlyruzs5i0”)
  9. /snap/nextcloud/28088/htdocs/lib/private/AppFramework/Http/Dispatcher.php line 127
    OC\AppFramework\Http\Dispatcher->executeController(OCA\Wopi\Controller\DocumentController {}, “index”)
  10. /snap/nextcloud/28088/htdocs/lib/private/AppFramework/App.php line 157
    OC\AppFramework\Http\Dispatcher->dispatch(OCA\Wopi\Controller\DocumentController {}, “index”)
  11. /snap/nextcloud/28088/htdocs/lib/private/Route/Router.php line 302
    OC\AppFramework\App::main(“OCA\Wopi\Cont … r”, “index”, OC\AppFramework\ … {}, {_route: “wopi.document.index”})
  12. /snap/nextcloud/28088/htdocs/lib/base.php line 993
    OC\Route\Router->match("/apps/wopi/index")
  13. /snap/nextcloud/28088/htdocs/index.php line 37
    OC::handleRequest()

GET /index.php/apps/wopi/index?fileId=11_ocqlyruzs5i0&requesttoken=B0bVB9kFsufS5Zpo9GLoaCM72jFzCtazwtEz7G6bX7E%3D%3ANQmlUJU12IGisOs8rQC4L0him0JKJbWB85t2q1%2FxDNU%3D
from 4.30 by at 2021-06-29T14:58:33+00:00