Failed to Connect


#1

Hi,

First time to spin up client, I enter the server address as: http://IP/nextcloud
I get:
Failed to connect to nextcloud at http://ip/nextcloud:
Server replied “404 Not Found” to “GET http://ip/nextcloud/nextcloud/status.php

This does work in the browser, and why is it looking for status.php under nextcloud/nextcloud/?

Thanks!


#2

The new 2.5.1 client was annonced a few days ago, did you use this version? Please try again and report to the bug tracker in case it is not working: https://github.com/nextcloud/desktop/issues


#3

I don’t know if there’s a bug or I’m just doing something wrong. First time I’ve tried to setup NextCloud so I’m suspecting the latter. Anyway, I still cannot get the account in the client to create. It can never locate the server and after 3 tries the client crashes. I have no idea what the next steps to try are.

BTW, I’m using 2.5.1.61652 as the client.


#4

OK, now thinking maybe it’s not the NC setup. I just installed the Apple client and it was able to connect my local server and reflect folder changes with no issues. For some reason, I can create an account in the Windows 10 NC client. Any ideas?


#5

More updates: I found the article about certificates and deleted some old ones that contained my DDNS location. After that, I was able to access the NC account from the browser using the external URL. I was still not able to setup the account in the Win 10 client. I also tried creating a new URL via No-IP, so that any older certs could not interfere and it still fails to setup the account in the client. I enter the URL in the server field and hit tab and the lock icon shows green, but when I hit Next, the client completely crashes with no errors or warnings other than the box expands out a bit just before crashing. Does this sound like a bug?


#6

You can test your ssl-setup in ssllabs.com. But then, please report the bug, the client should not crash.


#7

Thanks! SSLLabs checked out A+, and I was easily able to connect using the Owncloud client, so it’s a bug.