Failed to connect to

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face: is for home/non-enterprise users. If you’re running a business, paid support can be accessed via where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version: 13.0.1
Operating system and version: Archlinux
Apache or nginx version: Apache 2.4.33
PHP version: 7.2

The issue you are facing:
I found several entries in my logfile that state connection issues to www_nextcloud_com and to the app store.
When opening the app store through the webinterface, it needs at least 10 seconds to show up and than just shows my installed apps and some app bundles (in german “App Pakete”). Clicking on the app bundles-button takes even longer. Finally, it shows three bundles which are all composed of already installed packages. The log is being flooded with the entries which I included below
When searching for this issue, I often find solutions where the server is not connected to the internet. Therefore I did some ping-tests:

  1. my server --> www_nextcloud_com: I get some answers but there is ~97% package loss. I ran the test for some minutes and the answered packages are distributed over the entire run. The answers come with a normal latency.
  2. my server --> www_google_de: All requests are being answered (0% package loss)
  3. my desktop PC (different network) --> www_nextcloud_com: All requests are being answered.

So, what I know is that there is a very messy connection between my server and www_nextcloud_com while the overall internet connection of my server (dedicated server machine with gigabit-connection to the internet) seems to be very stable. Using my nextcloud over the internet works fine. Might it be that due to some misconfiguration, my server “spams” nextcloud_com and becomes therefore blacklisted for some time? The log entries do not seem to be too frequent unless I try to open the app store or try to look for updates.

Is this the first time you’ve seen this error? (Y/N): No

Steps to replicate it:

  • Just wait until my nextcloud instance tries to reach
  • Try to open the app store from the webinterface of my nextcloud installation

The output of your Nextcloud log in Admin > Logging:

GuzzleHttp\Exception\ConnectException: cURL error 7: Failed to connect to port 80: Connection timed out
Could not connect to appstore: {"Exception":"GuzzleHttp\Exception\ConnectException","Message":"cURL error 28: Connection timed out after 10001 milliseconds","Code":0,"Trace":"#0 /usr/share/webapps/nextcloud/3rdparty/guzzlehttp/guzzle/src/RequestFsm.php(103): GuzzleHttp\Exception\RequestException::wrapException(Object(GuzzleHttp\Message\Request), Object(GuzzleHttp\Ring\Exception\ConnectException))\n#1 /usr/share/webapps/nextcloud/3rdparty/guzzlehttp/guzzle/src/RequestFsm.php(132): GuzzleHttp\RequestFsm->__invoke(Object(GuzzleHttp\Transaction))\n#2 /usr/share/webapps/nextcloud/3rdparty/react/promise/src/FulfilledPromise.php(25): GuzzleHttp\RequestFsm->GuzzleHttp\{closure}(*** sensitive parameters replaced ***)\n#3 /usr/share/webapps/nextcloud/3rdparty/guzzlehttp/ringphp/src/Future/CompletedFutureValue.php(55): React\Promise\FulfilledPromise->then(Object(Closure), NULL, NULL)\n#4 /usr/share/webapps/nextcloud/3rdparty/guzzlehttp/guzzle/src/Message/FutureResponse.php(43): GuzzleHttp\Ring\Future\CompletedFutureValue->then(Object(Closure), NULL, NULL)\n#5 /usr/share/webapps/nextcloud/3rdparty/guzzlehttp/guzzle/src/RequestFsm.php(134): GuzzleHttp\Message\FutureResponse::proxy(Object(GuzzleHttp\Ring\Future\CompletedFutureArray), Object(Closure))\n#6 /usr/share/webapps/nextcloud/3rdparty/guzzlehttp/guzzle/src/Client.php(165): GuzzleHttp\RequestFsm->__invoke(Object(GuzzleHttp\Transaction))\n#7 /usr/share/webapps/nextcloud/3rdparty/guzzlehttp/guzzle/src/Client.php(125): GuzzleHttp\Client->send(Object(GuzzleHttp\Message\Request))\n#8 /usr/share/webapps/nextcloud/lib/private/Http/Client/Client.php(138): GuzzleHttp\Client->get('', Array)\n#9 /usr/share/webapps/nextcloud/lib/private/App/AppStore/Fetcher/Fetcher.php(106): OC\Http\Client\Client->get('', Array)\n#10 /usr/share/webapps/nextcloud/lib/private/App/AppStore/Fetcher/AppFetcher.php(71): OC\App\AppStore\Fetcher\Fetcher->fetch('"2018-04-09 09:...', '[{"id":"bookmar...')\n#11 /usr/share/webapps/nextcloud/lib/private/App/AppStore/Fetcher/Fetcher.php(170): OC\App\AppStore\Fetcher\AppFetcher->fetch('"2018-04-09 09:...', '[{"id":"bookmar...')\n#12 /usr/share/webapps/nextcloud/settings/Controller/AppSettingsController.php(182): OC\App\AppStore\Fetcher\Fetcher->get()\n#13 /usr/share/webapps/nextcloud/settings/Controller/AppSettingsController.php(395): OC\Settings\Controller\AppSettingsController->getAppsForCategory(3)\n#14 [internal function]: OC\Settings\Controller\AppSettingsController->listApps('app-bundles')\n#15 /usr/share/webapps/nextcloud/lib/private/AppFramework/Http/Dispatcher.php(161): call_user_func_array(Array, Array)\n#16 /usr/share/webapps/nextcloud/lib/private/AppFramework/Http/Dispatcher.php(91): OC\AppFramework\Http\Dispatcher->executeController(Object(OC\Settings\Controller\AppSettingsController), 'listApps')\n#17 /usr/share/webapps/nextcloud/lib/private/AppFramework/App.php(115): OC\AppFramework\Http\Dispatcher->dispatch(Object(OC\Settings\Controller\AppSettingsController), 'listApps')\n#18 /usr/share/webapps/nextcloud/lib/private/AppFramework/Routing/RouteActionHandler.php(47): OC\AppFramework\App::main('OC\\Settings\\Con...', 'listApps', Object(OC\AppFramework\DependencyInjection\DIContainer), Array)\n#19 [internal function]: OC\AppFramework\Routing\RouteActionHandler->__invoke(Array)\n#20 /usr/share/webapps/nextcloud/lib/private/Route/Router.php(297): call_user_func(Object(OC\AppFramework\Routing\RouteActionHandler), Array)\n#21 /usr/share/webapps/nextcloud/lib/base.php(998): OC\Route\Router->match('/settings/apps/...')\n#22 /usr/share/webapps/nextcloud/index.php(37): OC::handleRequest()\n#23 {main}","File":"/usr/share/webapps/nextcloud/3rdparty/guzzlehttp/guzzle/src/Exception/RequestException.php","Line":49}

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

    "system": {
        "maintenance": false,
        "loglevel": 1,
        "theme": "",
        "skeletondirectory": "\/home\/nextcloud\/data\/Admin\/files\/Administration\/Skeleton\/",
        "trashbin_retention_obligation": "auto, 90",
        "versions_retention_obligation": "auto, 180",
        "instanceid": "***REMOVED SENSITIVE VALUE***",
        "passwordsalt": "***REMOVED SENSITIVE VALUE***",
        "secret": "***REMOVED SENSITIVE VALUE***",
        "trusted_domains": [
        "memcache.local": "\\OC\\Memcache\\APCu",
        "memcache.locking": "\\OC\\Memcache\\Redis",
        "redis": {
            "host": "***REMOVED SENSITIVE VALUE***",
            "port": 0,
            "dbindex": 0,
            "password": "***REMOVED SENSITIVE VALUE***",
            "timeout": 1.5
        "filelocking.enabled": true,
        "datadirectory": "***REMOVED SENSITIVE VALUE***",
        "overwrite.cli.url": "https:\/\/",
        "dbtype": "mysql",
        "version": "",
        "dbname": "***REMOVED SENSITIVE VALUE***",
        "dbhost": "***REMOVED SENSITIVE VALUE***",
        "dbport": "",
        "dbtableprefix": "oc_",
        "dbuser": "***REMOVED SENSITIVE VALUE***",
        "dbpassword": "***REMOVED SENSITIVE VALUE***",
        "installed": true,
        "mail_smtpmode": "smtp",
        "mail_smtpauthtype": "LOGIN",
        "mail_from_address": "***REMOVED SENSITIVE VALUE***",
        "mail_domain": "***REMOVED SENSITIVE VALUE***",
        "mail_smtphost": "***REMOVED SENSITIVE VALUE***",
        "mail_smtpport": "465",
        "mail_smtpauth": 1,
        "mail_smtpname": "***REMOVED SENSITIVE VALUE***",
        "mail_smtppassword": "***REMOVED SENSITIVE VALUE***",
        "mail_smtpsecure": "ssl",
        "data-fingerprint": "8a2051323c7e6a6c384ed2d3d0e95b43",
        "ldapIgnoreNamingRules": false,
        "ldapProviderFactory": "\\OCA\\User_LDAP\\LDAPProviderFactory"

Sorry for the strage url-formating. As a new user, I am only allowed to use max. 4 links per post

I’m not sure that NC 13 is supported by PHP 7.2.

Solved the issue! It was related to my firewall settings. When I disable it, everything works as intended. However, I don’t understand the problem as the firewall only works for incoming connections and obviously not all ping answers are being blocked. Additionally, the nextcloud itself works fine with the firewall… Anyway, it now works well.
Besides the firewall issue, nextcloud 13.0.1 works with PHP 7.2.4 but it could be, that I had to install some custom packages from the AUR.

Recommended setup for running Nextcloud

1 Like