Extremely slow response to start loading the home page

Nextcloud takes very long time to just starts loading the home page.

Steps to reproduce

  1. Type Nextcloud URL in the browser and hit enter.
  2. Wait until it starts loading.

Expected behavior

Server specs are enough and I have enabled PHP and static content caching so response time much faster than that.

Installation method

Community Manual installation with Archive

Nextcloud Server version

29

Operating system

Debian/Ubuntu

PHP engine version

PHP 8.1

Web server

Nginx

Database engine version

MariaDB

Is this bug present after an update or on a fresh install?

None

Are you using the Nextcloud Server Encryption module?

Encryption is Enabled

What user-backends are you using?

  • Default user-backend (database)
  • LDAP/ Active Directory
  • SSO - SAML
  • Other

Configuration report

{
    "system": {
        "loglevel": 1,
        "instanceid": "***REMOVED SENSITIVE VALUE***",
        "passwordsalt": "***REMOVED SENSITIVE VALUE***",
        "secret": "***REMOVED SENSITIVE VALUE***",
        "overwrite.cli.url": "https:\/\/nextcloud.example.com",
        "trusted_domains": [
            "example.com",
            "nextcloud.example.com",
            "localhost",
            "Public_IP",
            "VPN_IP",
            "127.0.0.1"
        ],
        "datadirectory": "***REMOVED SENSITIVE VALUE***",
        "dbtype": "mysql",
        "version": "29.0.1.1",
        "dbname": "***REMOVED SENSITIVE VALUE***",
        "dbhost": "***REMOVED SENSITIVE VALUE***",
        "dbport": "",
        "dbtableprefix": "oc_",
        "mysql.utf8mb4": true,
        "dbuser": "***REMOVED SENSITIVE VALUE***",
        "dbpassword": "***REMOVED SENSITIVE VALUE***",
        "installed": true,
        "memcache.local": "\\OC\\Memcache\\APCu",
        "memcache.distributed": "\\OC\\Memcache\\Redis",
        "memcache.locking": "\\OC\\Memcache\\Redis",
        "redis": {
            "host": "***REMOVED SENSITIVE VALUE***",
            "port": 0
        },
        "twofactor_enforced": "true",
        "twofactor_enforced_groups": [
            "admin",
            "Users",
            "Fresh_Registration"
        ],
        "twofactor_enforced_excluded_groups": [],
        "mail_smtpmode": "smtp",
        "mail_sendmailmode": "smtp",
        "mail_from_address": "***REMOVED SENSITIVE VALUE***",
        "mail_smtpauth": 1,
        "mail_smtpname": "***REMOVED SENSITIVE VALUE***",
        "mail_smtppassword": "***REMOVED SENSITIVE VALUE***",
        "mail_domain": "***REMOVED SENSITIVE VALUE***",
        "mail_smtphost": "***REMOVED SENSITIVE VALUE***",
        "mail_smtpport": "465",
        "allow_local_remote_servers": true,
        "mail_smtpsecure": "ssl",
        "mail_smtpstreamoptions": {
            "ssl": {
                "allow_self_signed": true,
                "verify_peer": false,
                "verify_peer_name": false
            }
        },
        "maintenance_window_start": 1,
        "app_install_overwrite": [
            "xwiki"
        ],
        "maintenance": false,
        "theme": "",
        "enforce_theme": "",
        "updater.release.channel": "stable"
    }
}

List of activated Apps

Enabled:
  - bruteforcesettings: 2.9.0
  - calendar: 4.7.4
  - circles: 29.0.0-dev
  - cloud_federation_api: 1.12.0
  - collectives: 2.11.0
  - comments: 1.19.0
  - contacts: 6.0.0
  - contactsinteraction: 1.10.0
  - cospend: 1.6.1
  - dashboard: 7.9.0
  - dav: 1.30.1
  - deck: 1.13.0
  - encryption: 2.17.0
  - federatedfilesharing: 1.19.0
  - federation: 1.19.0
  - files: 2.1.0
  - files_downloadlimit: 2.0.0
  - files_pdfviewer: 2.10.0
  - files_reminders: 1.2.0
  - files_sharing: 1.21.0
  - files_trashbin: 1.19.0
  - files_versions: 1.22.0
  - firstrunwizard: 2.18.0
  - integration_jira: 1.1.0
  - logreader: 2.14.0
  - lookup_server_connector: 1.17.0
  - mail: 3.6.1
  - nextcloud_announcements: 1.18.0
  - notes: 4.10.0
  - notifications: 2.17.0
  - oauth2: 1.17.0
  - password_policy: 1.19.0
  - passwords: 2024.5.10
  - phonetrack: 0.8.1
  - photos: 2.5.0
  - privacy: 1.13.0
  - provisioning_api: 1.19.0
  - qownnotesapi: 24.4.0
  - recommendations: 2.1.0
  - registration: 2.4.0
  - related_resources: 1.4.0
  - serverinfo: 1.19.0
  - settings: 1.12.0
  - sharebymail: 1.19.0
  - spreed: 19.0.1
  - support: 1.12.0
  - survey_client: 1.17.0
  - systemtags: 1.19.0
  - tasks: 0.16.0
  - text: 3.10.0
  - theming: 2.4.0
  - theming_customcss: 1.16.0
  - twofactor_backupcodes: 1.18.0
  - twofactor_totp: 11.0.0-dev
  - updatenotification: 1.19.1
  - user_status: 1.9.0
  - viewer: 2.3.0
  - weather_status: 1.9.0
  - workflowengine: 2.11.0
  - xwiki: 0.1.2
Disabled:
  - activity: 2.21.1 (installed 2.20.0)
  - admin_audit: 1.19.0
  - breezedark: 28.0.0 (installed 28.0.0)
  - files_external: 1.21.0
  - registertocontact: 0.0.1 (installed 0.0.1)
  - secrets: 1.5.2 (installed 1.5.2)
  - suspicious_login: 7.0.0 (installed 6.0.0)
  - text2image_stablediffusion: 1.0.2 (installed 1.0.2)
  - user_ldap: 1.20.0

Nextcloud Signing status

No errors have been found.

Browser Dev Tools screenshot

Please post your nginx config.

Also your screenshot is not appearing.

I would enable the PHP slow error log. This usually provides information about such problems. Does this problem also occur if you deactivate all third-party apps like xwiki, qownnotesapi etc?

Is it really possible that redis is on port zero?
I also tried to create a system report. On the one I installed yesterday it turned out like this:

## Server configuration detail
Operating system: Linux 5.10.160-rockchip-rk356x #1.0.6 SMP Wed Apr 24 19:05:05 CST 2024 aarch64
Webserver: Apache/2.4.57 (Debian) (apache2handler)
Database: mysql 10.11.6
PHP version: 8.2.7
...
Nextcloud version: 29.0.1 - 29.0.1.1
...
    "redis": {
        "host": "***REMOVED SENSITIVE VALUE***",
        "port": 6379
    },

:rofl:REMOVED SENSITIVE VALUE

# ps ax | grep redis
    801 ?        Ssl    2:33 /usr/bin/redis-server "***REMOVED SENSITIVE VALUE***":6379

This is possible if a Unix socket is used.

Thank you. I haven’t tried it yet via sockets. Is the location of the socket also secret information? No kidding.

No, I wouldn’t consider it secret information but occ config:list does not differentiate based on the value that is specified, and thus the value is always marked as sensitive, regardless of whether it contains an IP address, a hostname or a socket.

At the same time, the values ​​in “trusted_domains” are left untouched. And here both addresses and names are indicated. However, returning to the problem under discussion, I can report the following. Nextcloud, which I installed yesterday, stopped being slow after disabling “Weather status”. Most likely, this is not a rule, but an exception to the rule. But it was like that.