External storage not working after update to 27.0 or 27.0.1 or after chaning from HAproxy to NGINX

Hi all,

I am using the Hansson IT Nextcloud VMware appliance in my homelab, which is updating itself weekly.

The problem is, that I cant see external file storage folders or shares which are based on external storages anymore when I am logged in via browser. And I dont see local files and folders in the nextcloud. But I see a random(?) folder which is located on one of the external storages, with some files in it after login.

When I use the nextcloud android or windows app, I still can see all external storage and all shares from this external storages. Everything is fine when I use the Apps.

Also, when i am in the admin console under Administration → External Storage, i see green checkmarks for each smb/cifs share. And I also can see that nextcloud is connecting to the file server in a packet capture.

I noticed this when a friend tried to access my nextcloud this week. So its not only with my account, but with every account.

I dont know when this problem orrured, because typically i access nextcloud with the android app most of the time, but not over the web ui. I am pretty sure that it worked with version 26, but since I have updated to v27, i was not on the nextcloud with a browser. So not sure if 27.0.0 or 27.0.1 is the possible problem.

Another reason could be the following:

I switche my HTTP load balance from HAproxy to NGINX a week ago. But I am not sure if this can be the reason, because all pages from the nextcloud look good. Only the File browser is messed up and do not show the correct contect.

But: I have a second nextcloud instance which is a fresh, manual install which will replace the old hansson IT appliance. This nextcloud instance is also behind the NGINX loadbalance and everything is working fine here. Exact same settings in NGINX. I gues the loadbalancer is not the problem.

Nextcloud version (eg, 20.0.5): 27.0.1
Operating system and version (eg, Ubuntu 20.04): Debian? Dont know, its the hansson nextcloud VM
Apache or nginx version (eg, Apache 2.4.25): dont know whats current version here, because I use the hansson IT VM
PHP version (eg, 7.4): smae like before

The issue you are facing:

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

Dont know hot to replicate it.

The output of your Nextcloud log in Admin > Logging:

{"reqId":"5kz8cFGlXinwYnCNp2dZ","level":2,"time":"2023-07-27T19:08:34+02:00","remoteAddr":"10.1.x.x","user":"admin","app":"suspicious_login","method":"POST","url":"/login","message":"Could not predict suspiciousness: No models found","userAgent":"Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:109.0) Gecko/20100101 Firefox/115.0","version":"","data":{"app":"suspicious_login"}}

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'passwordsalt' => 'salt',
  'secret' => 'secret',
  'trusted_domains' =>
  array (
    0 => 'localhost',
    1 => '10.1.x.y',
    2 => 'my.public.domain',
  'datadirectory' => '/mnt/ncdata',
  'dbtype' => 'pgsql',
  'version' => '',
  'overwrite.cli.url' => 'https://nextcloud/',
  'dbname' => 'nextcloud_db',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'dbuser' => 'nextcloud_db_user',
  'dbpassword' => 'dbpass',
  'installed' => true,
  'instanceid' => 'instancid',
  'upgrade.disable-web' => true,
  'log_type' => 'file',
  'logfile' => '/var/log/nextcloud/nextcloud.log',
  'loglevel' => '2',
  'log.condition' =>
  array (
    'apps' =>
    array (
      0 => 'admin_audit',
  'mail_smtpmode' => 'smtp',
  'remember_login_cookie_lifetime' => '50000',
  'log_rotate_size' => '0',
  'trashbin_retention_obligation' => 'auto, 60',
  'versions_retention_obligation' => 'auto, 180',
  'activity_expire_days' => '120',
  'simpleSignUpLink.shown' => false,
  'memcache.local' => '\\OC\\Memcache\\Redis',
  'filelocking.enabled' => true,
  'memcache.distributed' => '\\OC\\Memcache\\Redis',
  'memcache.locking' => '\\OC\\Memcache\\Redis',
  'redis' =>
  array (
    'host' => '/var/run/redis/redis-server.sock',
    'port' => 0,
    'timeout' => 0.5,
    'dbindex' => 0,
    'password' => 'pass',
  'default_phone_region' => 'de',
  'logtimezone' => 'Europe/Berlin',
  'htaccess.RewriteBase' => '/',
  'session_lifetime' => '50000',
  'session_keepalive' => 'false',
  'maintenance' => false,
  'mail_sendmailmode' => 'smtp',
  'mail_smtphost' => 'smtp.mail.server',
  'mail_from_address' => 'noreply',
  'mail_smtpport' => '465',
  'mail_domain' => 'public.domain',
  'mail_smtpauth' => 1,
  'mail_smtpsecure' => 'ssl',
  'mail_smtpauthtype' => 'LOGIN',
  'mail_smtpname' => 'username',
  'mail_smtppassword' => 'pass',
  'twofactor_enforced' => 'false',
  'twofactor_enforced_groups' =>
  array (
  'twofactor_enforced_excluded_groups' =>
  array (
    0 => 'admin',