External Storage doesn't sync - “Server is in maintenance mode”

Hello there,

I am using the following setup:

  • NextCloud 13.0.2 stable release
  • many Android based phones with the latest version of Nextcloud installed (Version 3.1.0)

it doesn’t sync data from external Storage and says, the server is in maintenance mode.

the Folders shows empty but files are there

It looks like this:

Any ideas on how to solve this issue?


have you checked if the nextcloud-instance is really in maintanence mode or not?

the maintenance mode is disabled or is there a special maintenance mode for mobile app connections?

nextcloud protocol error when i tap on sync

did you check if the external storage you connected to NC would work correctly using the NC web-site?

the web version works well

any chance to just restart your instance?

already done

@mario would you have an idea why their android is telling them their instance would be in maintenance mode and cant connect to their external storage?

Can you post output from status.php?

here’s the Output from status.php:


Considering we use maintenance from status.php to detect maintenace this is indeed strange. @tobiasKaminsky or @Andy maybe?

in apache access.log we can find a http 503 error when we enter a external storage directory over the app:

[28/Apr/2018:16:10:15 +0200] "PROPFIND /remote.php/webdav/Kollegium/ HTTP/1.1" 503 1075 "-" "Mozilla/5.0 (Android) Nextcloud-android/3.1.0"

No idea really. I thought that there are issues with external storage folders as-in the Android client isn’t supporting them, while I am not sure since I don’t know much about the external folders support in general. Hope Tobias does.

External storage issues known are:

i’ve set-up an external storage with another cloudservice (via webDAV - and it works like a charm)… so which external storages wouldn’t work with android-app so far, exactly? smb only?

but well i think both issues are the solution for this thread here.

smb is the only one I a m currently aware of, yes.

1 Like

sorry but where is the solution? we have set up nextcloud for 8300+ users and now you tell me SMB with the Andoird App wouldn’t work?

i’m sorry to hear about your problems…
the solution is: there are gitub-issues filed, devs do know about the problem and are working in it.
which means: there’s nothing more that we could do HERE in this forum about it. that’s the pityful truth. and so i marked it “solved”. it’s no good solution, though - as i know.

if you don’t wanna wait for the issues to get solved their common way… try buying support from nextcloud, inc. i bet there are special offers for educational clients.

Like @JimmyKater mentioned there are the following reported issues:


Both have never gotten any feedback by the original reporter when the devs asked for a test account so this is likely not going to be fixed since it would need to be reproduced first.
So if you are willing to support the devs e.g. with a test account then I am sure this will and can be fixed :+1:

1 Like

We created a test account and sent all data to @tobiasKaminsky