External storage, available for selection

Can you help me out.
I had the external storage app installed in NC20.
When i wanted to select there a group or user, is it not possible.
At first I see searching and then only blank.
When I type the user myself, it will be blank again at saving.


Unfortunately I don’t understand what you want to tell us. Can you please be more precise and describe IN DETAIL which steps you’re doing and where you want to find any users and groups?!

Thank you for reply. It is easy when you see it in front. Explain is sometimes difficult.

At the picture you can see the field I meant.
At setting I choose external storages (Administration).
I fill in Folder name, External Storage, Authentication, Configuration.
The last field is Available for. This field is always blank. I can not choose a user of group.
I tried to fill in a user myself, the NC20 recognized the user, but make the field blank again.



1 Like

Ok, thank you. Now I understand what you meant. Unfortunately I’m currently still on NC 19.0.3 and groups and users are displayed correctly. So someone else need to double-check if this is a general error or not. BTW, I’ve just found the following issue tickets, which could be an indication for a general problem:


Hi Peropjot,

I am having the same issue. Basically can’t add new external storages as I can’t select “Available for”. But old External storages work even though they do not show anything in it. Did anyone found solution for this, if not going back to 19 might be my only options.

Hope to hear from you soon! .

I have the same issue on a blank install, too. Just in external storage I’m unable to select users.

Same issue here! Cant select users so my external storage is mounted for all users!

Same issue! I’m hoping someone is able to help us soon :slight_smile:

I met the same problems!!

It’s been fixed… Replace the settings.js in nextcloud/apps/files_external/js with this one.


wow🤩 I’m gonna have a try! THX!

still the same…

Interesting. It fixed it for me.

Have you solved it, bro? I did the same, it’s no use…

You just update ‘files_external/js/settings.js’ to the latest version?

Yes and then rebooted, and it started working after that.

oh ! I fix it!! thx bro image
maybe need to clean all the cache before that
LOVE u :kissing_heart:

Thanks, It works great now !!!

1 Like

Probably a dull question, but how did you update it?

It is not difficult. As told, replace the settings.js in nextcloud/apps/files_external/js.
Reboot the system and empty the cache of your webbrowser.
Another way is to copy the changes and implement them in settings.js.