External mount point via WebDAV broke

Nextcloud version: 20.0.8
Operating system and version: CentOS 7
PHP version : 7.4

The issue you are facing:

I had mounted an external storage (Strato HiDrive) via WebDAV. For at least a year it worked fine. A couple of days ago I realized, that I cannot access it anymore in my nextcloud. Access via other clients is possible (nautilus, davfs). Also I use encryption, so the access via other clients does not help me to get my data back.

I cannot reproduce the exact time, the error occoured the first time.

I have other external mountpoints to Strato via SFTP, they work quite fine.

I created a new mountpoint to the same HiDrive via WebDAV, the same error occoured.

Is this the first time you’ve seen this error? : Y

Steps to replicate it:

  1. Configure external Storage to https://webdav.hidrive.strato.com
  1. Go to Apps->Folders and browse to the external cloud folder.

  2. Get Error Message “Storage is temporarily not available”

The output of your Nextcloud log in Admin > Logging:

Sabre\DAV\Exception\ServiceUnavailable: Storage with mount id 37 is not available

    /var/www/virtual/html/3rdparty/sabre/dav/lib/DAV/Tree.php - line 80:


    /var/www/virtual/html/3rdparty/sabre/dav/lib/DAV/Server.php - line 976:

    Sabre\DAV\Tree->getNodeForPath("files/USER... e")

    /var/www/virtual/html/3rdparty/sabre/dav/lib/DAV/Server.php - line 1678:

    Sabre\DAV\Server->getPropertiesIteratorForPath("files/USER... e", [ "{DAV:}get ... "], 1)

    /var/www/virtual/html/3rdparty/sabre/dav/lib/DAV/Server.php - line 1661:

    Sabre\DAV\Server->writeMultiStatus(Sabre\Xml\Wr ... ]}, Generator {}, false)

    /var/www/virtual/html/3rdparty/sabre/dav/lib/DAV/CorePlugin.php - line 363:

    Sabre\DAV\Server->generateMultiStatus(Generator {}, false)

    /var/www/virtual/html/3rdparty/sabre/event/lib/WildcardEmitterTrait.php - line 89:

    Sabre\DAV\CorePlugin->httpPropFind(Sabre\HTTP\Request {}, Sabre\HTTP\Response {})

    /var/www/virtual/html/3rdparty/sabre/dav/lib/DAV/Server.php - line 474:

    Sabre\DAV\Server->emit("method:PROPFIND", [ Sabre\HTTP ... }])

    /var/www/virtual/html/3rdparty/sabre/dav/lib/DAV/Server.php - line 251:

    Sabre\DAV\Server->invokeMethod(Sabre\HTTP\Request {}, Sabre\HTTP\Response {})

    /var/www/virtual/html/3rdparty/sabre/dav/lib/DAV/Server.php - line 319:


    /var/www/virtual/html/apps/dav/lib/Server.php - line 332:


    /var/www/virtual/html/apps/dav/appinfo/v2/remote.php - line 35:


    /var/www/virtual/html/remote.php - line 167:

    require_once("/var/www/vi ... p")
1 Like

In the meantime I updated to NC 21.0.1 and I use PHP 8.0. The Error is still the same.

1 Like