External Data Drive mounting Error (btrfs)

ncp
#1

My Nextcloud with data directory on an external USB-drive worked fine until I got this message trying to acces my cloud:

Internal Server Error

The server encountered an internal error and was unable to complete your request.
Please contact the server administrator if this error reappears multiple times, please include the >technical details below in your report.
More details can be found in the server log.

The USB-drive was no longer recognized:

root@nextcloudpi:~# lsblk
NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINT
sda 8:0 0 931.5G 0 disk
└─sda1 8:1 0 931.5G 0 part
mmcblk0 179:0 0 29.5G 0 disk
├─mmcblk0p1 179:1 0 43.9M 0 part /boot
└─mmcblk0p2 179:2 0 29.4G 0 part /

I tried to mount it again but it didn’t worked

mount /dev/sda1 /mnt

root@nextcloudpi:~# mount -t btrfs /dev/sda1 /mnt
mount: wrong fs type, bad option, bad superblock on /dev/sda1,
missing codepage or helper program, or other error

  In some cases useful info is found in syslog - try
  dmesg | tail or so.

I stored all my pictures on that drive so I really need your help!!!
(Auch gerne deutsche Antworten)

Thank you for your help

Jonas

#2

https://ownyourbits.com/2019/03/03/how-to-recover-a-btrfs-partition/

1 Like