Exception: Environment not properly prepared

After i updated my ubuntu server and my nextcould to the latest version everything fell apart.
i tried to repair it using the command nextcloud.occ maintenance:repair but that didn’t work. after that i did a complete new install for both ubuntu and nextcloud to see if it would work now. but after i reinstalled nextcloud i get the folling error.
Screenshot 2022-05-07 121652

i double check the permissions and even changed it with the command chmod 750. It would work for a little while but later on the error reappears.

I make use of a external disk for all my storage. this is how i mount the disk.
Screenshot 2022-05-07 121949

Does someone know how to fix it?

try changing your fstab users to user minus the s at the end.

keep us posted

I tried what you mentioned, but i still get the same error. The only thing different is that i can’t change the permissions on the mount point anymore. i get the error:
root@ubuntu:/var/snap/nextcloud/common/nextcloud# chmod 750 data/
chmod: changing permissions of 'data/': Read-only file system
root@ubuntu:/var/snap/nextcloud/common/nextcloud#

have you tried remounting it

mount -o remount,rw /dev/sdXn

where X is the drive and n is the partition number

so i made it work with a workaround. i make it mount it self with a systemd task. but now it will not load the dashboard from time to time and if i want to sync it with my phone it also doesn’t work