Excel files blocked because of the size of the title

Nextcloud 25.0.5
Linux 5.10.0-21-cloud-amd64 x86_64
PHP : 8.1.17
My SQL: 10.3.38

Nextcloud office 3.7.4
Desktop app 3.9.0

We are facing a pb that stress the user and cause a lot of calls to the support (and lake of confidence in Nextcloud :sob:.
Many xls files are blocked when we try to open them from the client desktop. We see the files but when we try to open it we have a message like “files can not be found, it must have been removed or nt any more in this folder”.

The same message appears when we try to “open it locally” from the web interface

It opens perfectly direcly from the web interface

We have seen that it happens when the size of the file (incliding the path) is more than 240 caracters. And it happens ofter with the sub-sub folder in the Group folders.

It does not happens with Word or Powerpoint?

Is there something to do ?

I think this has nothing to do with Nextcloud at all, but rather with an old and well-known Windows limitation, which limits the maximum path length to ~260 characters. Btw. this also occurs e.g. together with SharePoint or even with classic SMB shares.

See here: https://answers.microsoft.com/en-us/windows/forum/all/cannot-open-the-file-because-the-file-path-is-more/1753c8e0-57e4-4910-93ce-0e12716afc1d

and here:https://answers.microsoft.com/en-us/windows/forum/all/sharepoint-windows-file-path-limit/c42836df-32ce-4a95-81b2-70546e4be6d9

Apparently they removed the Path Limit some time ago, but it seems like you have to manually enable the new long path behavior: Maximum Path Length Limitation - Win32 apps | Microsoft Learn


OK thank you. I check with the IT department.

1 Like