Etherpad/calc not embedding in nc

i’m trying to set up etherpad-lite and ethercalc and access them in nc w ownpad.

i have both pad and calc setup on a separate domain on standard ports, and can access them directly. but when i try to access them thru nc, the instance doesn’t load in the window, instead the area is greyed out with a soft grey/white grid and a small link to the pad appears in the top left corner. it also appears in the name section on mouse over. if i click it, it happily redirects me to the working pad.

in the own pad settings the URLs are like ie the port is specified manually.

a strange thing about the calc instance is that if i run nc in tor browser it works, but not in vanilla ff. i tried allowing 3rd party cookies i ff to no avail.

(and pad doesn’t work in tor at all for me because of cookie errors. :frowning: which means i can’t just use tor always.)

if anyone has an inkling?

ah turns it surprise surprise it was an ff addon blocking the other domain.

my bad, sorry. but i was so confused about how to set it up because the etherpad docs are so confusing.