Es wurde kein PHP-Memory-Cache konfiguriert

NC 18.0.2 & php 7.4.3

Trotz aktivierten opcache wird mir angezeigt, dass kein Cache aktiviert sei!
Und: Das PHP-OPcache-Modul ist nicht geladen

Naja, ist geladen - nehme an das sich ds bus zu NextCloud 18.0.2 noch nicht herum gesprochen hat.
Soll man das bei GH als Bu melden - oder wie läuft das hier?

btw: dieses sogenannte Forum hier ist Megasch…

du hast das php upgedated, richtig?

bist du sicher, dass du die alten versionen komplett deinstalliert hast? falls ja: dann könnte es sich tatsächlich um einen fehler handeln. den solltest du dann bei github melden. aber dort wie hier gibt es einen code of conduct als auch eine netiquette.

sowas wird nirgends gern gesehen - und, ein hinweis unter freunden - es hinterlässt keinen guten eindruck von dir selbst. abgesehen davon mag es sein, dass sich viele diesen ton nicht gefallen lassen und lieber nicht antworten, auch wenn sie eine lösung hätten.
darüber hinaus: was erwartest und versprichst du dir von solchen ansagen? und: warum bist du hier, wenn es dich so nervt?

vlg
jimmy

Nein, ich habe nichts aktualisiert (hatte ich dazu etwas geschrieben?)!

Und warum sollte ich php aktualisieren?

Es war eine vollkommen neue Installation von NC 18.0.2 auf einem extra für diese Installation erstelltem Ordner auf einem eigenen Server (gemanaged).

Warum ich hier bin?
Weil ich - leider - nach Lösungen suchen muss, da NC offensichtlich nicht wirklich so fehlerfrei ist.
Und leider einer Schule etwas installieren wollte damit deren Unterricht weitergehen gehen kann.
Ansonsten würde ich NC nicht brauchen.

Und was GH oder/und Netiquette betrifft, nach über 20 jahren in dem Geschäft denke ich habe ich mehr als genug gesehen.
Meine Meinung darf ich aber schon sagen - oder?

natürlich. aber: der ton macht die musik. ganz so wie im unterricht auch.

kleiner tipp für alle, die mit dem community-forum von nextcloud unzufrieden sind (hier treffen sich freiwillige, die aus purer lust am helfen ihre erfahrungen weiter geben… niemand wird hier bezahlt. solche kleinigkeiten könnte man “nach über 20 jahren im geschäft” auch schon wissen): bildungseinrichtungen erhalten vergünstigten support von nc gmbh. einfach mal anfragen. fragen kostet nämlich gar nichts.

und bleibt noch die frage zu klären, wie DU dich verhalten würdest, würde jemand bei dir ankommen:
“diese verkackte schule und die dummen angestellten.
aber: ich brauche hilfe. hilf also mal.”
da wäre deine bereitschaft sicher nicht so hoch, demjenigen auch zu helfen. auch wenn das seine - möglicherweise - berechtigte meinung ist.

2 Likes

Hallo micp,

ich möchte hiermit keine Unfähigkeit unterstellen, es handelt sich bei dem folgenden nur um ein Ausschlussverfahren, da leider nicht genügend Informationen im Themenanfang sind, mit welchen man eine qualifizierte Lösung geben kann. (auch nach 20 Jahren Erfahrung, können einem kleine Fehler unterlaufen :wink: )

Kannst du anhand einer phpinfo nachstellen, dass das OPCache Modul tatsächlich geladen ist?

Dazu kannst du einfach eine phpinfo.php mit dem folgenden Inhalt im Root Verzeichnis der NC erstellen und dann im Browser aufrufen:

<?php

phpinfo();

Ansonsten wäre es hilfreich zu wissen, welches Betriebssystem+Version eingesetzt wird, da man so gegebenenfalls bessere Konfigurationshilfe leisten kann.

Wie sieht die PHP Konfiguration auf diesem System aus, sprich sind die notwendigen Konfigurationsdateien vorhanden und können auch von der php.ini geladen werden?

Ich habe NC 18.0.2 auf einem Debian 9 System mit aktuellem Apache und PHP 7.2.28 ohne OPCache Probleme laufen, daher glaube ich nicht, dass es an NC 18.0.2 liegt.

1 Like

Okay, das kann endlos werden.

Hatte bisher nie um Hilfe gefragt - oder?
Das Einzige was ich bisher geschrieben habe - und gefragt, wie das bei NC läuft (Bug/Issue bei GH oder hier im “Forum” etwas schreiben).

Bildungseinrichtungen & “vergünstigter Support”: aja, "vergünstigt.
Weiß ja nicht wie das in Deutschland ist, aber auch dort wird man ein “Budget” haben müssen, vorher das abklären usw.

Nur Covid-19 wird darauf sicher nicht warten …

Und auch wenn ich Hilfe (von hier ) benötigen sollte (welche es nicht geben wird), dieses Forum ist … (kann er sich selber aussuchen was es ist).

Damit ist diese Diskussion für mich beendet.
Bereinige des Fehler selber.

manche lehrer lernen es nicht mehr: sich selbst zu reflektieren. dabei steht das auch dem lehrpersonal gut zu gesicht.

Ist schon interessant was Sie sich hier alles “zusammenreimen”.
Deshalb wie geschrieben: für mich beendet.

Um auch das hier zu beantworten: wenn ich geschrieben habe, dass der OPCache aktiviert und geladen ist, aber NC das nicht versteht, dann habe ich mich vorher vergewissert dass es so ist!

Aber der Vollständigkeit halber:

RedHat
Apache 2.4 als FPM
Plesk Obsidian

Build Date|Feb 20 2020 20:26:29

Configure Command './configure' '--docdir=/opt/plesk/php/7.4/share/doc' '--infodir=/opt/plesk/php/7.4/share/info' '--localedir=/opt/plesk/php/7.4/share/locale' '--exec-prefix=/opt/plesk/php/7.4' '--sysconfdir=/opt/plesk/php/7.4/etc' '--includedir=/opt/plesk/php/7.4/include' '--prefix=/opt/plesk/php/7.4' '--libdir=/opt/plesk/php/7.4/lib64' '--sbindir=/opt/plesk/php/7.4/sbin' '--datadir=/opt/plesk/php/7.4/share' '--sharedstatedir=/opt/plesk/php/7.4/com' '--libexecdir=/opt/plesk/php/7.4/lib64' '--mandir=/opt/plesk/php/7.4/share/man' '--bindir=/opt/plesk/php/7.4/bin' '--localstatedir=/opt/plesk/php/7.4/var' '--build=x86_64-redhat-linux-gnu' '--host=x86_64-redhat-linux-gnu' '--disable-debug' '--disable-rpath' '--enable-calendar' '--enable-exif' '--enable-ftp' '--enable-litespeed' '--enable-phpdbg' '--enable-sockets' '--enable-sysvmsg' '--enable-sysvsem' '--enable-sysvshm' '--enable-xml' '--with-bz2' '--with-config-file-path=/opt/plesk/php/7.4/etc' '--with-config-file-scan-dir=/opt/plesk/php/7.4/etc/php.d' '--with-enchant=shared' '--with-gettext' '--with-gmp' '--with-iconv' '--with-kerberos' '--with-layout=GNU' '--with-libdir=lib64' '--with-libxml' '--with-openssl' '--with-pic' '--with-system-tzdata' '--with-zlib' '--without-gdbm' '--without-pear' '--disable-dba' '--disable-dom' '--disable-fileinfo' '--disable-gd' '--disable-json' '--disable-pdo' '--disable-phar' '--disable-posix' '--disable-sysvmsg' '--disable-sysvsem' '--disable-sysvshm' '--disable-xmlreader' '--disable-xmlwriter' '--enable-fpm' '--with-fpm-acl' '--without-curl' '--without-pspell' '--without-sqlite3' '--without-unixODBC' '--with-fpm-systemd' 'build_alias=x86_64-redhat-linux-gnu' 'host_alias=x86_64-redhat-linux-gnu' 'PKG_CONFIG=/var/jenkins/workspace/php-7.4-unix/rules/buck-out/gen/build/pkg-config.pex' 'CFLAGS=-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches -m64 -mtune=generic -fno-strict-aliasing -pipe -Wno-unused-function' 'CPPFLAGS=' 'CXXFLAGS=-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches -m64 -mtune=generic'|

Additional .ini files parsed 	/opt/plesk/php/7.4/etc/php.d/10-opcache.ini, /opt/plesk/php/7.4/etc/php.d/20-mysqlnd.ini, /opt/plesk/php/7.4/etc/php.d/50-xdebug.ini, /opt/plesk/php/7.4/etc/php.d/bcmath.ini, /opt/plesk/php/7.4/etc/php.d/curl.ini, /opt/plesk/php/7.4/etc/php.d/dba.ini, /opt/plesk/php/7.4/etc/php.d/dom.ini, /opt/plesk/php/7.4/etc/php.d/enchant.ini, /opt/plesk/php/7.4/etc/php.d/fileinfo.ini, /opt/plesk/php/7.4/etc/php.d/gd.ini, /opt/plesk/php/7.4/etc/php.d/imagick.ini, /opt/plesk/php/7.4/etc/php.d/imap.ini, /opt/plesk/php/7.4/etc/php.d/intl.ini, /opt/plesk/php/7.4/etc/php.d/json.ini, /opt/plesk/php/7.4/etc/php.d/ldap.ini, /opt/plesk/php/7.4/etc/php.d/mbstring.ini, /opt/plesk/php/7.4/etc/php.d/mysqli.ini, /opt/plesk/php/7.4/etc/php.d/odbc.ini, /opt/plesk/php/7.4/etc/php.d/pdo.ini, /opt/plesk/php/7.4/etc/php.d/pdo_mysql.ini, /opt/plesk/php/7.4/etc/php.d/pdo_odbc.ini, /opt/plesk/php/7.4/etc/php.d/pdo_pgsql.ini, /opt/plesk/php/7.4/etc/php.d/pdo_sqlite.ini, /opt/plesk/php/7.4/etc/php.d/pgsql.ini, /opt/plesk/php/7.4/etc/php.d/phar.ini, /opt/plesk/php/7.4/etc/php.d/posix.ini, /opt/plesk/php/7.4/etc/php.d/pspell.ini, /opt/plesk/php/7.4/etc/php.d/redis.ini, /opt/plesk/php/7.4/etc/php.d/snmp.ini, /opt/plesk/php/7.4/etc/php.d/soap.ini, /opt/plesk/php/7.4/etc/php.d/sodium.ini, /opt/plesk/php/7.4/etc/php.d/sqlite3.ini, /opt/plesk/php/7.4/etc/php.d/sysvmsg.ini, /opt/plesk/php/7.4/etc/php.d/sysvsem.ini, /opt/plesk/php/7.4/etc/php.d/sysvshm.ini, /opt/plesk/php/7.4/etc/php.d/tidy.ini, /opt/plesk/php/7.4/etc/php.d/xmlreader.ini, /opt/plesk/php/7.4/etc/php.d/xmlrpc.ini, /opt/plesk/php/7.4/etc/php.d/xmlwriter.ini, /opt/plesk/php/7.4/etc/php.d/xsl.ini, /opt/plesk/php/7.4/etc/php.d/zip.ini



Zend OPcache

Opcode Caching Up and Running
Optimization Enabled
SHM Cache Enabled
File Cache Disabled
Startup OK
Shared memory model mmap
Cache hits 633787
Cache misses 2000
Used memory 39855576
Free memory 94362152
Wasted memory 0
Interned Strings Used memory 6289896
Interned Strings Free memory 1112
Cached scripts 1999
Cached keys 1999
Max keys 16229
OOM restarts 0
Hash keys restarts 0
Manual restarts 0

Hättest du nicht müssen, wenn du keine Unterstützung haben möchtest!

Wie gesagt, man kann 10,20,30+ Jahre Erfahrung in einem Gebiet haben und es können einem dennoch Kleinigkeiten entgehen. Es ist noch kein Meister vom Himmel gefallen…sagt man ja so auf Deutsch, oder?

Danke! Damit kann man schon etwas anfangen und mir fällt sofort auf, dass hier Plesk im Einsatz ist. Bei Plesk ist das mit der Konfiguration von PHP Modulen und Parametern etwas anders, da man hier nicht einfach in einer Konfigurationsdatei rumdoktort, sondern alles über das Plesk Panel macht. Bei Änderungen, die man direkt in den Konfigurationsdateien macht, läuft man Gefahr, dass diese ignoriert werden und es dann zu so einem Verhalten kommen kann. Die Applikation kann keine Direktiven erkennen, wo keine sind.

Kannst du bitte einmal in den PHP Einstellungen des Mandanten in Plesk schauen, ob dort unter “Zusätzliche Anweisungen” die benötigten OPCache Parameter enthalten sind?

Sollten diese hier sein:

opcache.enable_cli=1
opcache.interned_strings_buffer=8
opcache.max_accelerated_files=10000
opcache.memory_consumption=128
opcache.save_comments=1
opcache.revalidate_freq=1

Es möchte Dir keiner etwas böses oder Unfähigkeit unterstellen, zumindest habe ich dies so noch nie erlebt in diesem Forum. Jeder, ob Laie oder Profi, werden hier alle gleich behandelt. Die Leute machen das alle aus freien Stücken und haben meist auch Spaß daran, anderen zu helfen, weil Sie einfach hinter dem Produkt stehen.

Um schnell an eine Lösung zu kommen, ist es daher immer praktisch, wenn man die Grundinformationen (Betriebssystem+Version, Webserver+Version, PHP+Version,NC+Version, Welche Informationen hat man schon gefunden und befolgt?, Welche anderen Schritte wurden bereits unternommen?) liefert.

1 Like

Interessant wäre auch der Inhalt von /etc/php/7.4/…

Ist mir auch schon passiert, dass trotz Installation hier die *.ini bzw. der Link auf die *.ini fehlte und ich händisch nachbessern musste. Das hat aber erstmal nichts mit NC selbst zutun.

Das Problem ist bekannt. Bug Report bei GitHub wird nicht benötigt.

2 Likes

Gibt es schon einen Status? Hab genau das selbe Problem…