Error with background job

Nextcloud version (eg, 20.0.5): 20.0.8
Operating system and version (eg, Ubuntu 20.04): Ubuntu 20.04)
Apache or nginx version (eg, Apache 2.4.25): nginx/1.18.0
PHP version (eg, 7.4): PHP 7.4.3 (cli) (built: Oct 6 2020 15:47:56) ( NTS )

The issue you are facing:

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

  1. tried to access my nextcloud
  2. “Cannot connect to server” message
  3. logged into server and rebooted
  4. again tried to access from browser, this time shown the “nextcloud is in maintenance mode” mesage
  5. turned maintenance mode off with occ maintenance:mode --off
  6. could then access the instance
  7. in settings>overview, message that a background job failed 4 hours ago
  8. checked log and see the following error message repeated every 5 minutes, seemingly endlessly:

The output of your Nextcloud log in Admin > Logging:

	OCA\DocumentServer\Document\DocumentConversionException:  # # Fatal error in v8::ToLocalChecked # Empty MaybeLocal. # Received signal 4 ILL_ILLOPN 7f9185959849 ==== C stack trace =============================== [0x7f918595aa92] [0x7f9184d643c0] [0x7f9185959849] [0x7f9185175072] [0x7f9185169fb1] [0x7f9185137ebe] [0x7f918512e643] [0x000000748550] [0x00000076011b] [0x000000767895] [0x00000076af1d] [0x00000054034f] [0x7f9184a350b3] [0x000000745f93] [end of stack trace] Illegal instruction (core dumped)

    /usr/share/nginx/nextcloud/apps/documentserver_community/lib/DocumentConverter.php - line 125:

    OCA\DocumentServer\Document\ConverterBinary->run()

    /usr/share/nginx/nextcloud/apps/documentserver_community/lib/DocumentConverter.php - line 80:

    OCA\DocumentServer\DocumentConverter->runCommand()

    /usr/share/nginx/nextcloud/apps/documentserver_community/lib/Document/DocumentStore.php - line 156:

    OCA\DocumentServer\DocumentConverter->saveChanges()

    /usr/share/nginx/nextcloud/apps/documentserver_community/lib/LocalAppData.php - line 102:

    OCA\DocumentServer\Document\DocumentStore->OCA\DocumentServer\Document\{closure}("*** sensiti ... *")

    /usr/share/nginx/nextcloud/apps/documentserver_community/lib/Document/DocumentStore.php - line 176:

    OCA\DocumentServer\LocalAppData->getReadWriteLocalPath()

    /usr/share/nginx/nextcloud/apps/documentserver_community/lib/Document/SaveHandler.php - line 58:

    OCA\DocumentServer\Document\DocumentStore->saveChanges()

    /usr/share/nginx/nextcloud/apps/documentserver_community/lib/BackgroundJob/Cleanup.php - line 71:

    OCA\DocumentServer\Document\SaveHandler->flushChanges()

    /usr/share/nginx/nextcloud/lib/public/BackgroundJob/Job.php - line 80:

    OCA\DocumentServer\BackgroundJob\Cleanup->run()

    /usr/share/nginx/nextcloud/cron.php - line 127:

    OCP\BackgroundJob\Job->execute()

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

<?php
$CONFIG = array (
  'instanceid' => 'xxxxxxxxxxxxxxxxxxxxx',
  'passwordsalt' => 'xxxxxxxxxxxxxxxxxxxxxxxxxxxxxx',
  'secret' => 'xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx',
  'trusted_domains' => 
  array (
    0 => 'www.xxxxxxxxxxxxxxxxxxx',
  ),
  'datadirectory' => '/usr/share/nginx/nextcloud-data',
  'dbtype' => 'mysql',
  'version' => '20.0.8.1',
  'overwrite.cli.url' => 'xxxxxxxxxxxxxxxxxx',
  'dbname' => 'nextcloud',
  'dbhost' => 'localhost:3306',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'xxxxxxxxxxxxxxx',
  'dbpassword' => 'xxxxxxxxxxxxxxx',
  'installed' => true,
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'mail_from_address' => 'example-address',
  'mail_smtpmode' => 'smtp',
  'mail_sendmailmode' => 'smtp',
  'mail_domain' => 'startmail.com',
  'mail_smtpauthtype' => 'LOGIN',
  'mail_smtpauth' => 1,
  'mail_smtphost' => 'smtp.startmail.com',
  'mail_smtpport' => '465',
  'mail_smtpname' => 'xxxxxxxxxxxxxxxxxxxx',
  'mail_smtppassword' => 'xxxxxxxxxxxxxxxxxxx',
  'mail_smtpsecure' => 'ssl',
  'maintenance' => false,
  'updater.release.channel' => 'stable',
  'theme' => '',
  'loglevel' => 2,
  'app_install_overwrite' => 
  array (
    0 => 'cookbook',
  ),
);


The output of your Apache/nginx/system log in /var/log/____:

<?php
$CONFIG = array (
  'instanceid' => 'xxxx',
  'passwordsalt' => xxx',
  'secret' => 'xxx',
  'trusted_domains' => 
  array (
    0 => 'www.example.com',
  ),
  'datadirectory' => '/usr/share/nginx/nextcloud-data',
  'dbtype' => 'mysql',
  'version' => '20.0.8.1',
  'overwrite.cli.url' => 'https://www.example.com',
  'dbname' => 'nextcloud',
  'dbhost' => 'localhost:3306',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'exampleuser',
  'dbpassword' => 'xxx',
  'installed' => true,
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'mail_from_address' => 'dysonsphere',
  'mail_smtpmode' => 'smtp',
  'mail_sendmailmode' => 'smtp',
  'mail_domain' => 'startmail.com',
  'mail_smtpauthtype' => 'LOGIN',
  'mail_smtpauth' => 1,
  'mail_smtphost' => 'smtp.example.com',
  'mail_smtpport' => '465',
  'mail_smtpname' => 'user@example.com',
  'mail_smtppassword' => 'xxxx',
  'mail_smtpsecure' => 'ssl',
  'maintenance' => false,
  'updater.release.channel' => 'stable',
  'theme' => '',
  'loglevel' => 2,
  'app_install_overwrite' => 
  array (
    0 => 'cookbook',
  ),
);


1 Like

I also have this problem in Nextcloud 20.0.9.

[documentserver_community] Error: OCA\DocumentServer\Document\DocumentConversionException:

Fatal error in v8::ToLocalChecked

Empty MaybeLocal.

Received signal 4 ILL_ILLOPN 7f8d6e4ad849

==== C stack trace ===============================

[0x7f8d6e4aea92]
[0x7f8d6d8a8730]
[0x7f8d6e4ad849]
[0x7f8d6dcc9072]
[0x7f8d6dcbdfb1]
[0x7f8d6dc8bebe]
[0x7f8d6dc82643]
[0x000000748550]
[0x00000076011b]
[0x000000767895]
[0x00000076af1d]
[0x00000054034f]
[0x7f8d6d57609b]
[0x000000745f93]
[end of stack trace]
Illegal instruction
at <>

  1. /mnt/Webserver/nextcloud/apps/documentserver_community/lib/DocumentConverter.php line 125
    OCA\DocumentServer\Document\ConverterBinary->run("/tmp/oc_tmp_sQCTqB-.xml", null)
  2. /mnt/Webserver/nextcloud/apps/documentserver_community/lib/DocumentConverter.php line 80
    OCA\DocumentServer\DocumentConverter->runCommand(OCA\DocumentServ … {})
  3. /mnt/Webserver/nextcloud/apps/documentserver_community/lib/Document/DocumentStore.php line 156
    OCA\DocumentServer\DocumentConverter->saveChanges("*** sensitive parameter replaced ***", ["78;AgAAADEA//8 … "], “/mnt/Webserver/ … x”, “docx”)
  4. /mnt/Webserver/nextcloud/apps/documentserver_community/lib/LocalAppData.php line 102
    OCA\DocumentServer\Document\DocumentStore->OCA\DocumentServer\Document{closure}("*** sensitive parameters replaced ***")
  5. /mnt/Webserver/nextcloud/apps/documentserver_community/lib/Document/DocumentStore.php line 176
    OCA\DocumentServer\LocalAppData->getReadWriteLocalPath(OC\Files\SimpleFS\SimpleFolder {}, Closure {})
  6. /mnt/Webserver/nextcloud/apps/documentserver_community/lib/Document/SaveHandler.php line 58
    OCA\DocumentServer\Document\DocumentStore->saveChanges(2675146154, [OCA\DocumentSer … "])
  7. /mnt/Webserver/nextcloud/apps/documentserver_community/lib/BackgroundJob/Cleanup.php line 71
    OCA\DocumentServer\Document\SaveHandler->flushChanges(2675146154)
  8. /mnt/Webserver/nextcloud/lib/public/BackgroundJob/Job.php line 80
    OCA\DocumentServer\BackgroundJob\Cleanup->run(null)
  9. /mnt/Webserver/nextcloud/cron.php line 127
    OCP\BackgroundJob\Job->execute(OC\BackgroundJob\JobList {}, OC\Log {})

at 2021-04-10T12:55:17+00:00

I severe the same issue since I moved to NC21. It seems I can edit documents in NC as usual. When I download a document I receive the first uploaded version

You’ve just made your sensitive config public, your nextcloud database credentials and your email credentials. You’ve miss pasted the webserver log with your not redacted NC config.
84 views, 82 chances you’re compromised.

Reported in the hope someone removes it, please change everything on the back-end.