Error wile Updating 20.0.8

I tried to update from 20.0.1 to 20.0.8 and get the following error message, and the podcast app is also being updated

"Update vorbereiten

Log-Level auf “debug” gesetzt

Wartungsmodus eingeschaltet

Reparaturschritt: Repair MySQL collation

Reparaturinformation: All tables already have the correct collation → nothing to do

Reparaturschritt: Repair SQLite autoincrement

Reparaturschritt: Copy data from accounts table when migrating from ownCloud

Reparaturschritt: Drop account terms table when migrating from ownCloud

Das Datenbankschema wird aktualisiert

Datenbank aktualisiert

Doctrine\DBAL\Exception\SyntaxErrorException: An exception occurred while executing 'ALTER TABLE oc_episodes ADD description VARCHAR(255) DEFAULT NULL, ADD podcastid INT NOT NULL, DROP author, CHANGE duration duration INT CHARACTER SET utf8mb4 NOT NULL COLLATE utf8mb4_bin, CHANGE playtime playtime INT CHARACTER SET utf8mb4 NOT NULL COLLATE utf8mb4_bin, CHANGE lastplayed lastplayed INT CHARACTER SET utf8mb4 NOT NULL COLLATE utf8mb4_bin': SQLSTATE[42000]: Syntax error or access violation: 1064 You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near ‘CHARACTER SET utf8mb4 NOT NULL COLLATE utf8mb4_bin, CHANGE playtime playt…’ at line 1

1 Like

Looks like some issue with the Podcasts App… @onny :wink:

Thanks for the info. The issue got also reported here Can't install/upgrade (#176) · Issues · onny / nextcloud-app-podcast · GitLab Hope to find a fix for the problem soon :open_mouth:

1 Like

Thx verry much! Have disabled the Podcast app and then update working like a dream!
Indeed it was the podcast app. After I deactivated that, the upgrade worked without any errors

Thanks for your help!

1 Like

Hi there,

I have also experienced this error while attempting to upgrade the podcast app. I am now stuck, as when I navigate to my nextcloud domain I am told “App update required”. If I “Start Update” it fails. I.e. I have no way to deactivate the app / access the nextcloud homepage (Etc.)

Could you please recommend a best next step?
Thanks in advance

Find the relevant part of the documentation for Nextcloud 15 here: https://docs.nextcloud.com/server/15/admin_manual/configuration_server/occ_command.html#apps-commands

The occ console is located in the Nextcloud directory, so you need to change to that directory first before issuing the command to disable the app (change capital letters to fit your needs):

cd /PATH/TO/NEXTCLOUD
sudo -u www-data php occ app:disable NAME_OF_APP

If you don‘t know the name of the app, you can list all apps with:

sudo -u www-data php occ app:list

Thanks Jozsef,

I followed your advice and successfully disabled the app. For clarify:

  • cd -ed to nextcloud
  • yum install php-process (following message ““The posix extensions are required - see http://php.net/manual/en/book.posix.php””)
  • sudo -u nginx php occ app:disable podcast

Successfully disabled, and confirmed.

Now, however authentication completely fails. The URL is <domain-name>/login?redirect_url=/apps/dashboard/. Inspecting the console, there is a “No OC found” message from JQuery, I presume. I don’t know JQuery so I’m not sure where to go from here. Any thoughts?

Worth mentioning:

  • updated all system packages
  • restarted nginx and php-fpm
  • cleared cookies.
  • Nothing is written to data/nextcloud.log when web browser auth fails.
  • Nothing is written to /var/log/nginx/error.log when web browser auth fails.

Thanks

OK. I fixed the issue, although I don’t understand the cause. I’m noting it here in case anybody experiences a similar issue.

Changing the group ownership of /var/lib/php/sessions from apache to nginx allowed for successful authentication.

This post referenced changing group ownership resolving an issue with php7.4. I am unfortunately unsure which version of php I had prior to upgrading all packages. However, I upgraded packages only after the login loop became an issue, which happened only after I disabled a single application, as per Jozsef’s instruction. Why disabling an application led to the login loop, I don’t know.