Error while trying to create admin user - Synology

I tried to install NC on my Synology DS418 with Apache 2.4, PHP 7.2, MariaDB 10 following this guide:

So far so goog, but when I try to create an admin user I get an error:
Error while trying to create admin user: Failed to connect to the database: An exception occurred in driver: SQLSTATE[HY000] [1045] Access denied for user ‘oc_InfectFTW’@‘localhost’ (using password: YES)

MariaDB PW

Do you know what the problem is?

Had that problem too. Solved via CLI:

cat dbuser
cat dbpassword

This will show your username and password for the db. Set up an admin account, but do NOT create a MySQL account. Use the credentials you got from the command.

Thank you for your answer.
Unfortunately I am not really firm with ssh and command window.

Could you please tell me where and when I have to use cat dbuser and cat dbpassword?

I am pretty sure it is in /your/path/to/nextcloud/config
and the command will be
grep dbuser config.php
grep dbpassword config.php
the answer will look like
‘dbuser’ => 'oc_InfectFTW’
‘dbpassword’ => ‘YourTopSecretPassword’
But this user has to exist in the DB with localhost and access rights to the nextcloud DB

Okay, sorry, but I need a few more steps :confused:

ssh -p 61122 user@ds418
“insert PW”
sudo su
“insert PW”

is this corect so far?

cd /volume2/nextcloud/config

Now I get an error “No such file or directory”

What am I doing wrong?

Does the directory /volume2/nextcloud/config exist?
What does “insert PW” mean?

hmm, it seems like, that the folder does not exist:

Microsoft Windows [Version 10.0.17763.973]
© 2018 Microsoft Corporation. Alle Rechte vorbehalten.

C:\Users\user>ssh -p 61122 user@ds418
infect@ds418’s password:
Infect@DS418:~$ sudo su
ash-4.3# dir
Downloads Drive
ash-4.3# cd/volume2/
ash: cd/volume2/: No such file or directory
ash-4.3# cd/volume2
ash: cd/volume2: No such file or directory
ash-4.3# cd /downloads
ash: cd: /downloads: No such file or directory
ash-4.3# dir
Downloads Drive
ash-4.3# cd /Downloads
ash: cd: /Downloads: No such file or directory

Do you know, what I am doing wrong?
“insert PW” means, that I insert my password

any ideas?

the first two command seems wrong:
cd /volume2
with a whitespace between cd (the command) and /volume2 (the target directory) trailing / is unimportant.
BTW what does the command
ls -la

Okay, it seems like the config does not exist.
Am I correct?
How can I proceed?

C:\Users\USER>ssh -p 61122 USER@ds418
infectATSYMBOLds418’s password:
InfectATSYMBOLDS418:~$ sudo su
ash-4.3# cd /volume2/
ash-4.3# dir
ATSYMBOLappstore aquota.user @database Gamez nextcloud ATSYMBOLsynologydrive ATSYMBOLtmp Bilder\ Tim ATSYMBOLeaDir homes ATSYMBOLSynologyApplicationService synoquota.db web
ash-4.3# cd /nextcloud/
ash: cd: /nextcloud/: No such file or directory
ash-4.3# cd /volume2/nextcloud/
ash-4.3# dir
ATSYMBOLeaDir index.html nextcloud.log

create a directory
mkdir -p /volume2/nextcloud/config
chown [nextcloudowner].[nextcloudownergroup] /volume2/nextcloud/config

replace [nextcloudowner].[nextcloudownergroup] with the real users.