Error when using outlook plugin

Hi everyone,

I tried using the Outlook plugin, but when I try to upload a file to a new mail, the plugin closes and I can read an error in the logging tab of the nextcloud web interface:

TypeError: Return value of OCA\Files_FullTextSearch\Events\FilesEvents::get() must be of the type string, integer returned at /var/www/nextcloud/apps/files_fulltextsearch/vendor/daita/my-small-php-tools/lib/Traits/TArrayTools.php#52

It happens every time i try to upload a file with the outlook plugin.
I’m using Outlook 2013 and nextcloud 14.

Do you have any information about this problem?

Thank you.

The question is why do you have an error with the fulltext search. Is it possible to disable fulltext search and see if it is working? In that case, it would be a bug report for the fulltextsearch.

Thank you for your reply.

I just disabled it and I had this error in addition to the previous one:

Error: Class 'OCA\FullTextSearch\Api\v1\FullTextSearch' not found

0. /var/www/nextcloud/apps/files_fulltextsearch/lib/Hooks/FilesHooks.php - line 67:
OCA\Files_FullTextSearch\Events\FilesEvents->onNewFile({ run: true, ... "})

1. /var/www/nextcloud/lib/private/legacy/hook.php - line 106:
OCA\Files_FullTextSearch\Hooks\FilesHooks::onNewFile({ run: true, ... "})

2. /var/www/nextcloud/lib/private/Files/View.php - line 1259:
OC_Hook::emit("OC_Filesystem", "post_create", { run: true, ... "})

3. /var/www/nextcloud/lib/private/Files/View.php - line 1187:
OC\Files\View->runHooks([ "create","write"], "/Outlook/Up ... b", true)

4. /var/www/nextcloud/lib/private/Files/View.php - line 268:
OC\Files\View->basicOperation("mkdir", "/Outlook/Up ... b", [ "create","write"])

5. /var/www/nextcloud/apps/dav/lib/Connector/Sabre/Directory.php - line 189:
OC\Files\View->mkdir("/Outlook/Up ... b")

6. /var/www/nextcloud/3rdparty/sabre/dav/lib/DAV/Server.php - line 1210:
OCA\DAV\Connector\Sabre\Directory->createDirectory("d50613ea635 ... b")

7. /var/www/nextcloud/3rdparty/sabre/dav/lib/DAV/CorePlugin.php - line 594:
Sabre\DAV\Server->createCollection("Outlook/Upl ... b", Sabre\DAV\MkCol {})

Sabre\DAV\CorePlugin->httpMkcol(Sabre\HTTP\R ... "}, Sabre\HTTP\Response {})

9. /var/www/nextcloud/3rdparty/sabre/event/lib/EventEmitterTrait.php - line 105:
call_user_func_array([ Sabre\DAV\ ... "], [ Sabre\HTTP ... }])

10. /var/www/nextcloud/3rdparty/sabre/dav/lib/DAV/Server.php - line 479:
Sabre\Event\EventEmitter->emit("method:MKCOL", [ Sabre\HTTP ... }])

11. /var/www/nextcloud/3rdparty/sabre/dav/lib/DAV/Server.php - line 254:
Sabre\DAV\Server->invokeMethod(Sabre\HTTP\R ... "}, Sabre\HTTP\Response {})

12. /var/www/nextcloud/apps/dav/appinfo/v1/webdav.php - line 80:

13. /var/www/nextcloud/remote.php - line 163:
require_once("/var/www/ne ... p")

There was no differences in the outlook plugin.
I think the plugin needs fulltextsearch.
Anyway, it really looks like a bug

I tried another version of the outlook plugin but I think I have a problem with the certificate, I can’t connect the plugin to the server anymore. That’s why I’m late to reply and the problem is not solved yet.

I’ll give news when I’ll have fixed this.

Thank you again.

the outlook plugin should not require fulltextsearch. The issue seems to appears when a new file is generated on your Nextcloud.

Can you upgrade the files_fulltextsearch app to the last version, and see if you still have an error when creating a new file ?

If you still have issue, please paste the result from:
./occ fulltextsearch:check

Ok, The connexion between nextcloud and the plugin works.

I reactivated fulltextsearch and upgraded everything.
I had the same error as at the beginning.

The result of ./occ fulltextsearch:check :

Full text search 1.1.0

- Search Platform:
Elasticsearch 1.0.2
    "elastic_host": [
    "elastic_index": "nmzpzaftbbtkeivotflyjiyoqt-index"

- Content Providers:
Files 1.1.1
    "files_local": "1",
    "files_external": "0",
    "files_group_folders": "0",
    "files_encrypted": "0",
    "files_federated": "0",
    "files_size": "20",
    "files_pdf": "1",
    "files_office": "1",
    "files_image": "0",
    "files_audio": "0"

Hello, just to verify the add-in does not use / require any non default installation add-ons.