Error when uploading some files types via Share Link (no issue while logged in)

Nextcloud version : 17.0.1
Operating system and version: Linux Kernel Ver 4.14.135-214.ELK.el7.x86_64
Apache or nginx version: 2.4.41
PHP version: PHP 7.3 (ea-php73) 7.3.12

The issue:

Thank you all very much in advance for your help. While I am logged in to the Dashboard as a User at, I am able to upload all file types that I have tried. However, when we create Share Links and test them, some (not all, but some) file types consistently fail and return an error message when trying to upload. The error is not related to file size, but rather file type. Error message: “Could not upload “[file name]”” for certain file types (PDF, AI, ZIP), even when those files are very small.

Is this the first time you’ve seen this error? (Y/N) : No: this has been the case for all Share Links we’ve tested.

Steps to replicate it:

  1. Visit
  2. Enter REDyellow
  3. Try to upload a PDF, AI, ZIP, RTF, TIF file (These file types fail, no matter how small they are, and return an error message. However JPG, docx, xlsx files upload just fine to a Share link).
  4. Note: all file types we’ve tested (including PDF, AI, ZIP, RTF, TIF) upload just fine while I am logged in to the Dashboard as a User at These file types (PDF, AI, ZIP, RTF, TIF) only fail while using the Share Links to upload them (this is the case for any Share Links we’ve created and tested). I can attempt to upload a PDF file via the Share Link, for example, and it will fail. I can upload the same exact file without any issue while I am logged in as a User.

The output of your Nextcloud log in Admin > Logging :

error gallery Exception: Can’t access a public resource that is upload only (404) 2019-12=11T11:45:30-0600

The output of your config.php file:

<?php $CONFIG = array ( 'instanceid' => 'REMOVED', 'passwordsalt' => 'REMOVED', 'secret' => 'REMOVED', 'trusted_domains' => array ( 0 => '', ), 'datadirectory' => '/home4/archoneo/public_html/cloud/data', 'dbtype' => 'mysql', 'version' => '', 'overwrite.cli.url' => '', 'dbname' => 'REMOVED', 'dbhost' => 'localhost', 'dbport' => '', 'dbtableprefix' => 'REMOVED', 'mysql.utf8mb4' => true, 'dbuser' => 'REMOVED', 'dbpassword' => 'REMOVED', 'installed' => true, 'maintenance' => false, 'theme' => '', 'loglevel' => 2, 'mail_smtpmode' => 'smtp', 'mail_smtphost' => '', 'mail_sendmailmode' => 'smtp', 'mail_from_address' => 'REMOVED', 'mail_domain' => '', 'mail_smtpport' => '465', 'mail_smtpsecure' => 'ssl', 'mail_smtpauthtype' => 'LOGIN', 'mail_smtpauth' => 1, 'mail_smtpname' => 'REMOVED', 'mail_smtppassword' => 'REMOVED', );

Exactly the same error on our site.
Nextcloud-Version 17.03.
Operating System: Debian 10
Apache 2.4.38
PHP: 7.3-14