Error when downloading big files

Hi
I keep getting an error when I want to download big files.
Here is the error I’m getting :slight_smile:

Citation
[index] Error: TypeError: Argument 2 passed to OC\Streamer::__construct() must be of the type int, float given, called in /var/www/html/nc/lib/private/legacy/OC_Files.php on line 164 at

  1. /var/www/html/nc/lib/private/legacy/OC_Files.php line 164
    OC\Streamer->__construct(OC\AppFramework\Http\Request {}, 2440907934, 19)
  2. /var/www/html/nc/apps/files/ajax/download.php line 64
    OC_Files::get("/Software/Windows/Microsoft Office", “Office 2019 Pro … T”, {head: false})
  3. /var/www/html/nc/lib/private/Route/Route.php line 156
    require_once("/var/www/html/n … p")
  4. <>
    OC\Route\Route->OC\Route{closure}("*** sensitive parameters replaced ***")
  5. /var/www/html/nc/lib/private/Route/Router.php line 317
    call_user_func(Closure {}, {_route: “files_ajax_download”})
  6. /var/www/html/nc/lib/base.php line 1008
    OC\Route\Router->match("/apps/files/ajax/download.php")
  7. /var/www/html/nc/index.php line 37
    OC::handleRequest()
    GET /index.php/apps/files/ajax/download.php?dir=%2FSoftware%2FWindows%2FMicrosoft%20Office&files=Office%202019%20Pro%20Plus%20%2B%20Visio%20%2B%20Project%20-%20ODT&downloadStartSecret=vrsjx0e85yd
    from 192.168.88.250 by ak at 2021-02-28T11:55:14+11:00
    <>

Does anybody has the same error ?

How large are this big files? Are you using a 32-bit system?

These two bug reports mention the same error messages:

1 Like

I m on a raspberry Pi :
Linux akncnc 4.19.75-v7+ #1270 SMP Tue Sep 24 18:45:11 BST 2019 armv7l GNU/Linux

The thing is it use to work well since one day…

How could I missed that one.

In this file : nc/lib/private/Streamer.php

By changing construct(IRequest $request, int $size with construct(IRequest $request, $size it’s working!

Thanks @tflidd

Thanx, it fix for me also.
On Nextcloud 21 problem exists and i cannot use “Download All Files” button even on folders smaller than 1Gb
Odroid XU4 Linux odroid 5.4.98-219 #1 SMP PREEMPT Mon Feb 15 21:15:05 EST 2021 armv7l armv7l armv7l GNU/Linux