Error updating from 15.0.5 to 15.0.07

Update stops at “Move new files in place” with error

Could not rename /mnt/nxtc/updater-ocs5mt1a7lw4/downloads/nextcloud/lib/public/Encryption/IFile.php to /var/www/html/nextcloud/updater/…/lib/public/Encryption/IFile.php

Any one know how to deal with this issue?


UPDATE: When i click “Retry Update” it moves on to another file. When I check the location that it’s trying to rename, i see the file located there.

UPDATE 2: Continuously clicked “Retry Update” until it finally allowed me to complete update. Finished update and now on 15.0.7. Problem with updater?


I’m having the same issue upgrading from 16.0.4 to 16.0.5 in a freebsd jail

2019-10-03T01:01:49+0000 sE3VWEEmin [info] rollbackChanges("10")
2019-10-03T01:01:49+0000 sE3VWEEmin [info] unlink .step
2019-10-03T01:01:49+0000 sE3VWEEmin [info] rollbackChanges - step >= 7
2019-10-03T01:01:49+0000 sE3VWEEmin [info] end of  rollbackChanges()
2019-10-03T01:01:50+0000 Yer8IlX2Rh [info] request to updater
2019-10-03T01:01:50+0000 Yer8IlX2Rh [info] currentStep()
2019-10-03T01:01:50+0000 Yer8IlX2Rh [info] POST request for step "10"
2019-10-03T01:01:50+0000 Yer8IlX2Rh [info] startStep("10")
2019-10-03T01:01:50+0000 Yer8IlX2Rh [info] moveNewVersionInPlace()
2019-10-03T01:01:50+0000 Yer8IlX2Rh [info] storage location: /mnt/storage/updater-ocoxlslmcu9a/downloads/nextcloud/
2019-10-03T01:01:50+0000 Yer8IlX2Rh [error] POST request failed with other exception
2019-10-03T01:01:50+0000 Yer8IlX2Rh [error] Exception: Exception
Message: Could not rename /mnt/storage/updater-ocoxlslmcu9a/downloads/nextcloud/apps/notifications/l10n/cs.js to /usr/local/www/nextcloud/updater/../apps/notifications/l10n/cs.js
#0 /usr/local/www/nextcloud/updater/index.php(1062): Updater->moveWithExclusions('/mnt/storage/up...', Array)
#1 /usr/local/www/nextcloud/updater/index.php(1357): Updater->moveNewVersionInPlace()
#2 {main}

I’m having the same issue when updating from 17.0.0 to 17.0.1 (month-old setup, first update here).
get a “Could not rename” error that can be bypassed when resuming the update.
Currently having a break from spamming “retry update” button as OP suggested, never thought I’d have to click so many times.

Server is on Ubuntu. Nextcloud storage is on a CIFS mount whereas HTML content is on a local storage. File permission seem correct to me (-rwx------ on both sides with the right user) .

I gave it a second try on my next update and managed to solve the issue.
My CIFS mount was owned by a different group than the one in my www-data folder (nextcloud:nextcloud instead of nextcloud:www-data). Aligning the group to www-data solved the update issue.

Thanks, sephrat. I was having the same issue and that fixed it for me.