Error running nc limits


Nextcloud version (eg, 20.0.5): 23.0.2
Operating system and version (eg, Ubuntu 20.04): raspbian debian bullseye 11
Apache or nginx version (eg, Apache 2.4.25): 2.4.52
PHP version (eg, 7.4): 7.4

The issue you are facing:

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

  1. run nc-limits

The output of the ncp.log

[ nc-limits ] (Thu Mar 17 22:33:43 CET 2022)
grep: /etc/php/7.4/fpm/conf.d/90-ncp.ini: No such file or directory
grep: /etc/php/7.4/fpm/conf.d/90-ncp.ini: No such file or directory
Using 2983732224B for PHP
sed: can’t read /etc/php/7.4/fpm/conf.d/90-ncp.ini: No such file or directory
sed: can’t read /etc/php/7.4/fpm/conf.d/90-ncp.ini: No such file or directory
sed: can’t read /etc/php/7.4/fpm/conf.d/90-ncp.ini: No such file or directory

I would like to run the nc-limits.
The Problem is that i get the above error. I have found this:

where it is handling a similar issue but with php 7.2.
As described there, the easiest way is to do a fresh OS installation is no opinion for me.
Any chance to get that fixed without reinstalling the whole system…?


no one…? Am I doing something wrong. I nearly do not get any answer to my problems…?!

This is exactly what you should do and why you didn’t get an answer until now…

That is a solution for every problem.! So I would suggest to close this forum and put a general information on the landing page, please delete everything and do a fresh installation!
That makes no sense at all…! if others would act like that we also would not accept it…
Oh you have a problem with your macOS… Ok than reinstall please everything…

Oh you have a problem with Windows 11, than please reinstall it, because we have no other solution…!

this is absolutely nonsens…!

1 Like

well, for windows, there is absolutely no solution…

For linux, you always have solution…

That’s the difference between closed-ecosystem and open-source solutions.

Now, it might also be some Raspberry technical limitation…and you did not provide any model…

But, looking at fpm/conf.d/90-ncp.ini: No such file or directory looks more like a failed php-fmp install:
apt-get install -fto repair/fix any failed install or to track package mismatch.
apt-get install php7.4-fpm to install
apt-get reinstall php7.4-fpm to reinstall with

Have you tried to desinstall/purge php7.4 and reinstall it with the modules you need…
even upgrade to php8.0

Thank you…
I am coming from php8 as I did not get any reply to this thread:

I have purged 8 and installed 7.4

The NCP summary page is saying that everything is ok and also from the logs i can not see any problem with php.

tried now to reinstall php7.4. unfortunately still no luck…

BTW it is a rPi 4