Error on upgrade: Stuck on "starting code integrity check"

Support intro

Sorry to hear you’re facing problems :slight_frown:

If you’re urgently looking for support to keep your business running, consider checking out our paid support options.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:

example

Or for longer, use three backticks above and below the code snippet:

longer
example
here

Remember, the below information may be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Please delete everything above when creating your topic, just provide the following:

Nextcloud version (eg, 12.0.2): 11
Operating system and version (eg, Ubuntu 17.04): macOS 10.11.6
Apache or nginx version (eg, Apache 2.4.25):
PHP version (eg, 7.1): 7.0

The issue you are facing: Upgrade (? -> 11) is stuck on step “Starting code integrity check”.

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

  1. I started the upgrade via the web interface, it faced me whether to keep the maintenance mode enabled or not -> the upgrade was successful, but not completed…
  2. switched to the command line with sudo -u _www php occ upgrade
  3. Retried step 2 multiple times, tried things in between, I’m stuck on this screen:

00

The output of your Nextcloud log in Admin > Logging:

pls tell me where to find in the file system

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

<?php
$CONFIG = array (
  'instanceid' => 'ozz4m',
  'passwordsalt' => 'NpJzzzz+C',
  'secret' => 'q40PTYuRzzzzzzfQnZ1',
  'trusted_domains' => 
  array (
    0 => 'clzzzd.de',
  ),
  'datadirectory' => '/Vzzzzalfeld.de/data',
  'overwrite.cli.url' => 'https://clzzzzld.de',
  'dbtype' => 'sqlite3',
  'version' => '9.1.6.1',
  'logtimezone' => 'UTC',
  'installed' => true,
  'ldapIgnoreNamingRules' => false,
  'ldapProviderFactory' => '\\OCA\\User_LDAP\\LDAPProviderFactory',
  'mail_from_address' => 'sjzzzud',
  'mail_smtpmode' => 'php',
  'mail_domain' => 'szzzzzzeld.de',
  'maintenance' => true,
  'loglevel' => 0,
  'updater.secret' => '$2y$1zzzzzbbsuCoiKOJ/ohp.',
);

The output of your Apache/nginx/system log in /var/log/____:

[Wed Jan 03 16:46:22.381584 2018] [authz_core:error] [pid 10659] [client 841.206:51875] AH01630: client denied by server configuration: /Volumes/My Book Thunderbolt Duo/Library/Server/Web/Data/Sites/Default/
[Wed Jan 03 16:48:22.610259 2018] [authz_core:error] [pid 10698] [client 806:51896] AH01630: client denied by server configuration: /Volumes/My Book Thunderbolt Duo/Library/Server/Web/Data/Sites/Default/

I guess, thats the wrong log location…

Meanwhile I did the following:

  • made some additional upgrades via the web updater (cli not working yet) with the hope that wrong files get replaced
  • Faked the nextcloud lib/base.php so that I can run the database upgrade via the web -> exits with “ein fehler ist aufgetreten” at the same point.
  • changed to php 7.1. -> upgrade still not working.

Just remember, that you can always perform a full manual install, instead of an update. Just shutdown your webserver and install the latest base installtion. Make sure, that you have made a backup of your config.php, of course. This has always worked for me.

I already tried the manual upgrade (download of the tarball) as described in the documentation, but this didn’t worked for me as well. Maybe something is broken with the sqlite (this is the default one, right?) database.

Next step will be a new install of the cloud, as you propose. Hopefully no big deal, as I all the logic and data of my instance is saved in either the ldap-server or external storage.

I don’t think, that this is the database. As the log on the screenshot shows it being functional.
How exactly did you go about installing the latest tarball?