Error on login screen after update from 9.0.53 to 10.0.1

After “successful” update of nextcloud, I was suck on the login screen with “system error” message.

in the log file I have the message:
{“reqId”:“5vcnJXzmVFt6XRH26Q4z”,“remoteAddr”:“x.x.x.x”,“app”:“PHP”,“message”:“OCP\AutoloadNotAllowedException: Autoload path not allowed: /var/www/owncloud/apps/dav/lib/connector/sabre/exceptionloggerplugin.php at /var/www/owncloud/lib/autoloader.php#152”,“level”:3,“time”:“2016-11-26T22:05:34+00:00”,“method”:“PROPFIND”,“url”:"/remote.php/webdav/",“user”:"–"}

I noticed that, since version 9.0.53, the first character in some folder names were “capitalized”.

Example pwd from version 9.0.53:
The same from version 10.0.1:

I think this is the reason for the error, but I am unable to find where those paths are defined.

Please help

Your error message looks as if you did update wrongly. When updating always remove all files except the config and the data folder. In your case this looks like you still have old files existent as well.

Thank you for you suggestion, but that cannot be the case.
I removed the entire “/var/www/owncloud” directory and copied the new unzipped version instead of it.
Then I copied my old "config.php file to “var/www/owncloud/config” directory and re-linked my “data” directory back (In my case “/var/www/owncloud/data” is symbolic link).
Of course, before all of that I first stopped my apache2 server.

My apologies. It looks that I looked in the old log file “owncloud.log”. Log file is now named “nextcloud.log”.
I am not sure any more which log messages belong to which version (I roll-backed the version).
I will try update again to get the real log entries.

I succeeded repeating the same procedure for the third time.
The only difference is that i disabled, during the installation, running of cron.php (I commented the line in /etc/crontab).

What about apps, themes, etc?